0
$\begingroup$

I recently purchased scatter 4 pro off the blender exchange and have had some issues installing it. I am running on a 2020 MacBook Pro with macosx and blender 2.93. In terms of summarizing the issue to the best of my ability:

I go to install the zipped file in blender and go to activate it through the search menu however the plugin doesn't appear at all once I search for it.

I also tried moving some files such as the __init__.py and Lodify.py and a few others into the add-on directory folder prior to installing the plugin inside of blender. This was able to make the scatter add on appear in the search menu, but when I went to activate the add on the prompt "Import Error Module Not Found" followed by different file names depending on the files I had moved over before the install through blender.

I've tried everything I can personally think of with no luck. If anyone has any solutions or insight into this issue it would be greatly appreciated.

$\endgroup$
3
  • 2
    $\begingroup$ That's a third-party addon so you'd better ask on the addon author's web site. However, the normal way to install an addon from a zip file is to click the 'Install' button on the Preferences > Addons tab and select the Zip file with the file selector. That should do the installation automatically without having to place files yourself. $\endgroup$
    – John Eason
    Commented Aug 17, 2021 at 21:20
  • $\begingroup$ ... and the installation instructions are here. $\endgroup$
    – John Eason
    Commented Aug 17, 2021 at 21:30
  • $\begingroup$ Thank you for the response, and I tried reaching out to the creator but have yet to receive a response. And I followed the normal procedure to the T as with all plugins. It seems to register the install process as all the contents are moved into the add on folder. However whenever I go to search for the scatter plugin in blenders add-on section to activate it, it does not appear. This is where I am confused. $\endgroup$
    – Wupyaup
    Commented Aug 18, 2021 at 2:34

1 Answer 1

0
$\begingroup$

I was able to get in touch with the developer and the fix is quite simple. When installing a blender plugin on macOS you must turn off your browser automatic unzipping MacOS is doing the unzip for you automatically and that leads to manual error

To do this go to Safari > Preferences > General and then untick the box for Open "safe" files after downloading

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .