0
$\begingroup$

I'm baking a 1024x1024 Shadow map for a character and I'm getting a lot of triangular artifacts around the eyes and banding around the upper skull and jaw.

shadowMap for head and hands

I don't think I've encountered this before - does anybody know what's causing this or how I can get rid of it?

EDIT - IMAGES IN RESPONSE TO COMMENTS enter image description here Separated the maps a little more in response to comments, but this doesn't seem to affect the texture bake outcome.

$\endgroup$
6
  • 1
    $\begingroup$ Check Face orientation (Normals) ... $\endgroup$
    – vklidu
    Aug 12 '21 at 12:46
  • $\begingroup$ Also check smoothing of high and low poly object, and make sure auto smoothing is turned off for both models as well $\endgroup$
    – James
    Aug 12 '21 at 12:55
  • $\begingroup$ @vklidu - Normals seem normals, have added the .blend in case you can see any issue there. $\endgroup$ Aug 12 '21 at 14:53
  • $\begingroup$ @James - Autosmoothing is turned off. Have added the .blend above in case you can see any issue with it. $\endgroup$ Aug 12 '21 at 14:54
  • $\begingroup$ Your UV map is heavily overlapping ... $\endgroup$
    – vklidu
    Aug 12 '21 at 18:18
0
$\begingroup$

Black triangles on hands are defects of overlapping faces of your UVmap ... like now some of them shares same pixels. So you have to change those parts manually or use Unwrap > Smart.

enter image description here

The "triangles" on smooth surface are the same you can see when you change shading to Flat ... Smooth shading is not calculated in bake.

enter image description here

I'm not a master so I don't knot if this is a limit or error, but you can avoid that by increasing Subdivision modifier temporarily for baking. Like here with Render Level 6.

enter image description here

Edit: It seems to me it is (surprisingly for me) Terminator issue. When I go to Properties Editor > Object Properties tab > Shading > Shadow Terminator Offset and set 0.25 it seems to be gone without Subdiv modifier increasing.

$\endgroup$
2
  • $\begingroup$ Deleted my comments. I did try the Terminator Offset youtube.com/watch?v=oecXkpAoq9U but didn't seem to get great results. Are you using any subdivision at this point? What are your settings, Terminator Offset aside? Thanks for the efforts! $\endgroup$ Aug 12 '21 at 20:59
  • $\begingroup$ Just Subdiv modifier at 2 and Terminator as written 0.25 ... Since I started to use a different lightninghan yours, I will check that again tomorrow. Issue doesn't look like a Terminator, but seemed to me it worked for bake. $\endgroup$
    – vklidu
    Aug 12 '21 at 21:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.