3
$\begingroup$

I am trying to simulate a simple blanket onto the bed (a plane subdivided 20 times). All the objects that the blanket will fall are set as collisions. The cloth has self-collisions turned on. The simulation was cached. Why is this happening and how can I fix it? Thanks.

This is the blend file: pasteall.org/blend/8e4c1cc2d10e4a6d876a66314851fa33 enter image description here

enter image description here

$\endgroup$
2
5
$\begingroup$

The following seemed to help:

  1. Increase the quality step from your rather low number (i used 55)
  2. For the collision object i decreased the Outer Thickness (to the default of 0.02)

Here's my smooth result at frame 23 (i cut down to a 30 frame simulation to save time):

enter image description here

and the changed file

next time consider the https://blend-exchange.com/ uploader that is more convenient to post your blend file.

$\endgroup$
5
  • $\begingroup$ Hi, Thank you, the simulation works but only up until frame 23. After that, it just shriveled up like a piece of wrinkly paper. Does that mean I have to increase the quality steps again? Why does this happen in Blender? $\endgroup$
    – Ming
    Aug 11 '21 at 18:56
  • $\begingroup$ @Ming -- do you mean frame 23 in YOUR file or in my Solution file? My file that I uploaded (from you file that I downloaded) shows no shriveling or explosion. Indeed you should have an adequate number of quality steps. Seems like 55 was sufficient, perhaps even 30. $\endgroup$
    – james_t
    Aug 12 '21 at 21:41
  • $\begingroup$ I tried to replicate your results in my file (quality steps and reverting back to the default outer thickness). The problem persists. I then tried to increase the outer thickness after watching youtube.com/watch?v=V0ziiFFEbJo. I then tried to isolate the bed/table/blanket to its own blender file but it gets worse the more stuff I want the blanket to collide with. What should I be looking out for when a cloth object needs to collide with multiple objects? $\endgroup$
    – Ming
    Aug 12 '21 at 22:25
  • $\begingroup$ Here is the blend file.<img src="https://blend-exchange.com/embedImage.png?bid=5EDNow6m" /> $\endgroup$
    – Ming
    Aug 12 '21 at 22:28
  • $\begingroup$ @Ming -- I had a quick look at the video. Is there a time unit where they suggest setting the outer thickness to higher than the default 0.02? I couldn't find that. I see it set to 0.02 at time unit 2:39. $\endgroup$
    – james_t
    Aug 12 '21 at 23:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.