2
$\begingroup$

So, for some reason, whenever I pose the model, the eyebrows move with the mesh. However, when I render it, the eyebrows remain in the default position. Any ideas on how to remedy this? Here is the model enter image description here

$\endgroup$
3
  • $\begingroup$ Could you attach an image? $\endgroup$
    – stern38
    Aug 10, 2021 at 8:43
  • $\begingroup$ I attached it to the post. $\endgroup$
    – Mole
    Aug 10, 2021 at 8:50
  • $\begingroup$ you should try to upload this to another cloud platform. Google chrome e.g. refuses to download your file due to security risks $\endgroup$
    – Chris
    Aug 10, 2021 at 10:32

1 Answer 1

1
$\begingroup$

Preface

It's a clash of Surface Deform vs Subdivision Surface modifiers vs Simplify option.

In the Render Settings the [X] Simplify option is turned on with a Max Subdivision value of 0 for Subdivision Surface modifiers. This means that for better performance in the viewport all Subdivision Surface modifiers are disabled, but active when the image is rendered.

simplify settings

The disabled Subdivision Surface modifier has a red icon. And just to note, it's additionally disabled in the viewport by the "monitor" icon.

disabled modifier

How It Breaks

The eyebrows are attached to the head with a Surface Deform modifier. The modifier needs to be bound on a vertex base. This binding was done when Simplify was already active. As a result of this, the Surface Deform modifier uses the low-poly version of the head (without the Subdivision Surface modifier's modification) and the eyebrows are on the right spot.

But when you now render the image, then the Subdivision Surface modifier kicks in and messes up the Surface Deform modifier and the eyebrows warp around in space.

Bad News First

You cannot have the eyebrows fixed in the viewport and render when you want to use the Simplify option. But you can have it fixed in the render and messed up in the viewport when Simplify is on. Or you can have it fixed in the viewport and render but Simplify turned off. But you can't have it all.

How to fix it

Long story short, to fix it rebind the Surface Deform modifier when the Subdivision Surface is modifier active and has the correct number of levels.

  • in the Render Settings, uncheck the [_] Simplify checkbox -or- set Max Subdivision to 1
  • select the eyebrows, and go to the modifiers tab
  • there are two Surface Deform modifiers, [X] remove one. (It's probably a leftover from the join of the left and right eyebrow but you only need one now.)
  • here you should now see the warning that the vertice count differs: surface deform modifier
  • click the Unbind button, the button will change.
  • click the Bind button to rebind

That's it. Done.

Keep in mind that the "Subsurf" modifier on the body/head must have the same number of levels for the viewport and the render. And that you need to rebind the Surface Deform each time when you change the number of levels.

$\endgroup$
1
  • $\begingroup$ Wow. I'm gonna have to get that a try, when I get back to working on Blender. Thanks. $\endgroup$
    – Mole
    Aug 18, 2021 at 21:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .