0
$\begingroup$

so I posted a question a little while ago about artifacts appearing when using the boolean union modifier to attach two objects. I was able to solve it by setting the boolean to Fast and making sure the normals were facing outwards.  Another problem what that the union of the gums to the main body created bizarrely non-manifold faces inside of the mesh. Unfortunately, these non manifolds are where my new problems lie.

I tried to click the Make Manifold button after joining the gums (MONSTER TEETH copy.194) to the main mesh (BODY_Cube.010), but that made a few of the gums disappear.

I tried Select>Select All By Trait> Non-Manifold, and I'm able to select the verts, but not the faces within them. enter image description here

 If I delete the vertices, It deletes the mesh around the gums.

enter image description here

I tried using JMESH addon and using the Join and Remesh option, but whenever I do that, it ends up distorting the mesh of the gums like this:

enter image description here

I also tried adjusting the over lap threshold on the Boolean modifier (set to Union), but that isn't helping either.

Is there any way to quickly and cleanly remove these manifolds???

Here is a copy of the project.

$\endgroup$

1 Answer 1

1
$\begingroup$

not sure if this is the best solution, but I got around this problem by applying a Remesh modifier with the voxel size set to .03. Then I used the Decimate modifier to bring the poly count down. That got rid of the inside faces which were causing the non-manifolds.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .