0
$\begingroup$

I am having difficulty rendering my animation. The project file itself is pretty simple with the majority of verts being from a Blender Kit asset. The total amount of verts is rather low for a sene and is less than 100'000.

In a previous project I was able to render with a vert count of almost 2.3 million.

The animation in my project file is baked and when I render a single frame it works just fine. Everything renders as it should and that includes all the optimization settings as well (i.e., motion blur etc.) But if I render the animation in full it renders 1 frame and then crashes.

I have tried looking at all of my optimization settings and everything seems fine. I even shared my project file with someone else and they were able to render the animation just fine so this indicates that the file is not corrupt in any way.

Also, I have tried rendering different animations from different project files and they all seem to work just fine... I could start it all over again but I don't see the point in this. It is far more conducive to try and figure out what the problem actually is to stop it from ever happening again.

screenshot of car and road

https://1drv.ms/u/s!ApRFx-cmg8aB2B035j2jAnGAwuDL?e=fxrqJG

My system hardware is the following

  • Razer Blade 2019 (mid)
  • RTX 2080 Max Q
  • 32GB RAM
  • Windows 10
$\endgroup$
2
  • 1
    $\begingroup$ 100,000 verts? Erm, no. It's 700,000 something for the char and you have added a Subdivision Surface modifier that bumps the count up to almost 1,3 million verts. $\endgroup$
    – Blunder
    Aug 8 at 0:27
  • 1
    $\begingroup$ Is this for Eevee or Cycles? The output is called 'Eevee Car Crash Test' but the engine is actually Cycles: imgur.com/a/rPpI85H $\endgroup$
    – Blunder
    Aug 8 at 2:16
2
$\begingroup$

Remove the Subdivision Surface modifier from the car. It has 781,255 verts. This should be enough.
Change the output format to PNG so every frame is rendered and saved to disk, and you don't lose your work when Blender crashes.
Convert the rendered image sequence in the Video Editor workspace to the final video file.

Update / Crash report:

  • I've done a mini render (10% size, 128 samples, CPU, NLM denoise, 64 tile size for CPU render) and Blender crashed at frame 12. I've continued the render (start frame 13) and it rendered the remaining 88 frames without a crash.
  • Second try (25% size, but lowered samples to 50). It stopped at frame 1. Restarted it and ... it crashed:
    Stack trace:
    blender.exe         :0x00007FF72A19CE10  btGjkEpaPenetrationDepthSolver::calcPenDepth
    blender.exe         :0x00007FF729FCAB40  RB_dworld_set_gravity
    blender.exe         :0x00007FF72941DCC0  rigidbody_update_simulation
    blender.exe         :0x00007FF72941B9A0  BKE_rigidbody_do_simulation
    blender.exe         :0x00007FF72941C040  BKE_rigidbody_eval_simulation
    blender.exe         :0x00007FF72D12AF50  std::_Func_impl_no_alloc<std::_Binder<std::_Unforced,void (__cdecl&)(Depsgraph * __ptr64,Curve * __
    blender.exe         :0x00007FF72D129380  blender::deg::anonymous namespace'::evaluate_node blender.exe         :0x00007FF72D129330  blender::deg::anonymous namespace'::deg_task_run_func
    tbb.dll             :0x00007FF813D651D0  tbb::interface7::internal::isolate_within_arena
    blender.exe         :0x00007FF72D1AE500  tbb::internal::function_task::execute
    tbb.dll             :0x00007FF813D737A0  tbb::recursive_mutex::scoped_lock::internal_try_acquire
    tbb.dll             :0x00007FF813D737A0  tbb::recursive_mutex::scoped_lock::internal_try_acquire
    blender.exe         :0x00007FF7296D9F80  tbb::internal::task_group_base::wait
    blender.exe         :0x00007FF72D128EC0  blender::deg::deg_evaluate_on_refresh
    blender.exe         :0x00007FF7293505D0  scene_graph_update_tagged
    blender.exe         :0x00007FF7294EDAD0  wm_event_do_notifiers
    blender.exe         :0x00007FF7294D84D0  WM_main
    blender.exe         :0x00007FF7291C9C70  main
    blender.exe         :0x00007FF72D6D3468  __scrt_common_main_seh
    KERNEL32.DLL        :0x00007FF81EA07960  BaseThreadInitThunk
    ntdll.dll           :0x00007FF82181A2D0  RtlUserThreadStart
  • so I had a look at the Scene Properties > Rigid Body World > Cache. There I've clicked Bake All Dynamics => 100 frames, 19kb baked. Finally, it rendered all 100 frames without a crash. I am not sure if this solved the problem or it was just a coincidence.
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.