0
$\begingroup$

Ok I have an interesting observation. Looks to me that blender isn't able to render out a pure color. I need to add a black background to my character, and it has to be PURE black. But when I put it into Photoshop to check, it is clearly not pure black. So I disconnected literally all my nodes, and then it defaults to black in the compositor, just to make sure its not the Alpha over node, and wouldn't you know, it's still not working.

Anyone have any ideas?

https://i.imgur.com/rzNZ7Ee.gif <-- Just showing me rendering it without nodes. (Same thing happens when I use the alpha over node.

https://i.imgur.com/i5PIpX8.gif <-- Showing in PS how its not all pure black.

I've tried turning on and off different color management options, file types, colors, etc, and nothing changes it.

This can be tested and done in ANY blender file. If you get different results, let me know.

$\endgroup$
6
  • $\begingroup$ please provide blend file $\endgroup$
    – Chris
    Aug 6, 2021 at 4:25
  • $\begingroup$ Hello and welcome. Instead of having users go through links and external sites please use the builtin tools to embed images in your post. See How to upload an image to a post? or GIFs $\endgroup$ Aug 6, 2021 at 11:09
  • 1
    $\begingroup$ @Chris You can open any blend file, "use nodes" in compositor, cut the line between "Render layers" and "Composite" node, and you'll have my setup. Render that out, and It won't be pure black, like illustrated in my second GIF. I've tried many files, and new files, newest blender on steam plus the newest experimental 3.0 version. They give the same result. $\endgroup$ Aug 6, 2021 at 17:10
  • $\begingroup$ @DuarteFarrajotaRamos Thanks, I'll fix it when I get back home. $\endgroup$ Aug 6, 2021 at 17:10
  • $\begingroup$ @WilliamSebastianRudi: of course i can do that. But if i were you - and i want help from others - i would it make as easy as possible for them to help. And providing a blend file makes it very easy to help and so the "helpers" don't have to waste their time. But yeah, you can also describe how to do it and hope that someone wants to help. but obviously...until now...nobody wanted to help. $\endgroup$
    – Chris
    Aug 6, 2021 at 17:49

1 Answer 1

0
$\begingroup$

I figured it out. It was the Dither setting under post processing.

What is dithering you might ask? I didn't know either. enter image description here

Here you have an example. In a nutshell its to create a better percieved transition in color where there is a limited palette.

This is activated by default in blender.

Thanks for all the responses.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.