1
$\begingroup$

Hey so I am doing a body horror sculpt project in Blender 2.92. Basically, I'm having a man's abdomen open up into a mouth with teeth.  enter image description here

Unfortunately, whenever I use the boolean modifier, and set it to union, to add the gums holding the teeth for the monster mouth, I get a bizarre result. 

I tried flipping the normals, but that still gives me some weird results.

This is what it looks like when I flip the normals on the outside for just the main body. Some of the gums disappear. enter image description here

This is what it looks like when I flip the normals on the outside for the gums and the body. Some of the gums disappear (just like last time), AND a few of them will even cut holes into the main body. enter image description here

Finally, this is what it looks like when flip the normals to the inside for both the main body and the gums. None of the gums disappear nor do they cut holes into the main body, but I get these weird artifacts in the mesh of the main body. When I try to smooth it out with the smooth brush, it just makes it worse. enter image description here

Also, when I set all of the normals to the outside like this, enter image description here I'm still having a few problems when trying to apply the boolean modifier (to the second row of smaller gums). It'll look like the picture below where most of the gums are deleted and a few of them will even cut holes into the main mesh (circled in red). enter image description here

Does anyone know how to fix this problem so that when I apply the boolean modifier and setting it to union), the gums will fuse smoothly (with no artifacts in the mesh)???

Here is a link to a copy of the project. The vertex count is kinda high. If you need me to use a decimator modifier to lower the poly count, I'll be more than happy to do that. 

$\endgroup$

1 Answer 1

2
$\begingroup$

your face orientation looks like this:

enter image description here

red is bad, so in edit mode, select all with A and then Mesh->normals->recalculate outside. You have to do it for your whole model until all is looking like this:

enter image description here

then you can use your boolean modifier and it will work.

Changing the solver to fast/exact helps often. Yes, sounds weird, but sometimes it works with fast better, sometimes with exact.

$\endgroup$
7
  • $\begingroup$ Thanks @Chris! So I flipped the normals so they all look blue like this picture 1. But when I try to apply the boolean (set to union) on the second row, some of the gums holding the teeth go missing and they'll even be holed cut into the mesh like in this picture linked below. picture 2. Is there anything else I should do? $\endgroup$ Commented Aug 6, 2021 at 0:53
  • $\begingroup$ Yes, upload your file again without applying your Boolean and tell me the object which has the Boolean and I will check again… $\endgroup$
    – Chris
    Commented Aug 6, 2021 at 2:34
  • $\begingroup$ Sure thing, @Chris! So the object that has the boolean is the "BODY." The "BODY" is the main object. I am trying to fuse "MONSTER GUMS ROW 2" onto the "BODY." Here is the new project file. $\endgroup$ Commented Aug 6, 2021 at 3:10
  • $\begingroup$ change the solver to "fast" in the boolean modifier. This helped when i tried it $\endgroup$
    – Chris
    Commented Aug 6, 2021 at 4:12
  • $\begingroup$ Hey! That actually did kinda help. However, for a few of them, I am still getting some weird artifacts like this. Do you think there's any way to get rid of those? $\endgroup$ Commented Aug 6, 2021 at 16:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .