2
$\begingroup$

I'm working on a simple scene where I've got a table set to a collision object and a plane strip of with a couple of subdivisions (previously a much larger plane) set to a cloth simulation I then let fall on the table, to fake a table cloth, but every single time I run the simulation it keeps jittering, intersecting with the table, colliding with some sort of margin (so not actually touching the table) and, worse of all, flies off after a coupe of seconds, as shown in the attached GIF.

enter image description here

I've tried changing the cloth's Quality Steps and cloth preset, enabled Self Collision but the issue still persists. Has anyone figured a good way to fix these issues?

(Any suggestions welcome 🙂!)

Blender file can be found here:

EDIT 1:

I've tried Chris' suggested Self-collision settings and that seems to fix the jitters and flying away of the plane, but there's still a gap/margin once the plane collides with the table as shown below: enter image description here enter image description here

Updated blend file:

EDIT 2

Chris' suggestion of going into the Cloths settings > Object Collision > and setting the Distance to ~0.002m seems to reduce the margin significantly, see comparison below:

enter image description here

$\endgroup$
6
  • $\begingroup$ you could search for questions here on SE...there were a lot of similar questions. Or provide your blend file. $\endgroup$
    – Chris
    Aug 5 at 7:55
  • 1
    $\begingroup$ Hey Chris 👋🏾, I'm currently looking through some of the suggestions but haven't found a good fix yet, and I've just updated the post with the blend file, so feel free to let me know what could help in fixing it 🙏🏾 $\endgroup$
    – Abraham S.
    Aug 5 at 7:56
  • $\begingroup$ Increase the poly count of the cloth quite significantly $\endgroup$
    – James
    Aug 5 at 8:02
  • $\begingroup$ @James: nope, that won't help - maybe you should first TEST your proposals if you are not sure. $\endgroup$
    – Chris
    Aug 5 at 8:06
  • 2
    $\begingroup$ As Chris says, lower down the Self Collisions Distance value, also maybe increase the Collisions Quality value $\endgroup$
    – moonboots
    Aug 5 at 8:08
2
$\begingroup$

UPDATE: for the margin issue:

change object collision distance like so, quality to 8 and you get (maybe increase subdivisions of plane a bit):

enter image description here


go into your physics properties and turn down your distance like this:

enter image description here

result:

enter image description here

$\endgroup$
7
  • $\begingroup$ Thank you so much for downloading the file @Chris and testing out the fix Chris! I've created a new plane and gave it the self collision settings from your screenshot and while that fixes the jitters and the flying off, there's still an issue with the gap/margin with the collision object (the table), does anyone know why that happens? $\endgroup$
    – Abraham S.
    Aug 5 at 8:34
  • $\begingroup$ can you show a screenshot of that margin? or upload for update blend file? $\endgroup$
    – Chris
    Aug 5 at 8:41
  • $\begingroup$ Sure things! I've now added the screenshots and updated blend file. Thanks in advance 🙏🏾 $\endgroup$
    – Abraham S.
    Aug 5 at 8:43
  • $\begingroup$ Apologies for my late reply, just finished from work and tried out your fix. I went into the Cloth's Collisions settings and reduce the distance to 0.002 which seems to reduce it significantly (though not 100% fully). And also noticed that once I scale up the plane/cloth, the jitters for some reason reappear on collision. Though your fix alone allows me to move forward, so thank you massively for helping me with this. $\endgroup$
    – Abraham S.
    Aug 5 at 17:17
  • 1
    $\begingroup$ Thank you!! I appreciate that!!! $\endgroup$
    – Chris
    Aug 5 at 17:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.