1
$\begingroup$

Yesterday my animation playback was running at a grand speed in solid mode - think it was at the 24fps. Today, its around 4fps. I didn't actually change anything as far as I'm aware.

I tried opening it up on a stronger computer - now it's running at like 8fps.

Does anyone know why this might be?

Blender File:

$\endgroup$
8
  • 1
    $\begingroup$ "I didn't actually change anything as far as I'm aware." Pretty sure you did, otherwise there wouldn't have been such a drastic change. So you have to tell us what changed between today and yesterday so we can help you. Try hiding individual parts of your scene to diagnose which objects are causing it $\endgroup$ Aug 4, 2021 at 9:24
  • $\begingroup$ You must have changed something... modifiers are lowering your fps very much, do you use modifiers? subdivision modifier on your objects that are moving? Did you make objects more dense with vertices? $\endgroup$
    – MikoCG
    Aug 4, 2021 at 9:33
  • $\begingroup$ Hi Duarte. Unless I pressed a certain key by mistake, I simply saved and shut down my computer last night with the animation running fine. Opened it today and the playback much slower. There is only one character in my scene. $\endgroup$ Aug 4, 2021 at 9:34
  • $\begingroup$ @MikoCG yes, I have a subdivision modifier and an armature modifier. Is there a way to disable these? They were enabled yesterday when it was working fine however! $\endgroup$ Aug 4, 2021 at 9:36
  • $\begingroup$ One can accidentally click on something and not notice - in Playback settings for example, the default is No Sync, which means, play every frame. Could you have had it on Frame Dropping before and accidentally changed it back to No Sync? $\endgroup$
    – Susan
    Aug 4, 2021 at 10:30

1 Answer 1

1
$\begingroup$

I started your animation and got 6 fps on my computer.

If you select your body, go to modifiers tab and lower your "levels viewport" to 1 -> i got 24 fps on my computer which is 4 times faster and pretty good for a 3 seconds change, i think ;) You should keep the viewport levels low (for faster working/animating) and increase the render levels (because then you need the good quality, you don't really need the good quality for working in viewport).

enter image description here

$\endgroup$
1
  • $\begingroup$ @EmmaCulhane As Chris said, you don't need the high level in your viewport. Of course, there might be occasions where you need a high resolution in the viewport to see exactly what you are doing etc., but it makes no sense if the render resolution is much lower - because then you'll get in the final animation what you saw in the viewport. So generally speaking you should usually go for a lower resolution in viewport than in render - or t least they should match if you want to know how the render will turn out. But low render with high viewport only slows down your workflow for no use at all. $\endgroup$ Aug 6, 2021 at 9:49

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .