B"H With 2.93 trying to form an audio visualizer with mesh cylinders instanced to all vertices on geometry node grid. Looked in Manual 2.93/Blender stack exchange/multiple tutorials. Geometry Nodes were initially formed with mesh circle. Deleted geometry node input. Added geometry-grid, point instance and mesh cylinder. With point instance node, selected cylinder.
How to decrease scale so cylinders not overlap? When scaled down the cylinder in 3d viewport, the size of the instanced cylinders is not altered. Then tried multiple variations of geometry node combinations (including transform node before and/or after pt instance; object info node scale connected to point instance....) without any change in size of instanced cylinders. Thank you.


1 Answer 1


Just scale down your cylinder in Edit mode, then all instances will be scaled.

Another option: Use the point scale node before the Point Instance node. Otherwise, it scales the points in the instances. This has the same effect.

  • $\begingroup$ Maybe add: the Point Scale node before the Point Instance node. Otherwise, it scales the points in the instances. ( I've only just discovered you can nest Point Instancing.. you can instance more objects on the vertices of instanced objects ) $\endgroup$
    – Robin Betts
    Aug 3, 2021 at 17:35
  • $\begingroup$ thank you! added! $\endgroup$
    – Chris
    Aug 3, 2021 at 17:59
  • $\begingroup$ B"H Chris and Robin, Sequentially tried to scale 1st mesh cylinder then instanced cylinders in Edit Mode. Will try again Thank you! Also thank you very much the prompt response! It worked. 0.361 THANK YOU!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! $\endgroup$
    – user32848
    Aug 6, 2021 at 18:17
  • $\begingroup$ If my answer helped, please check the checkmark legato my answer. Thank you! $\endgroup$
    – Chris
    Aug 6, 2021 at 18:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .