0
$\begingroup$

Having issues with rendering image in Cycles. I made a custom texture for my object through an tutorial and messing around with the nodes. But now I noticed that when I try to render a Image in Cycles that the texture is al deformed and also missing some parts and seperate objects I modeled. Any ideas how to fix this?

https://ibb.co/qJnWcvM https://ibb.co/H7sYqTs https://ibb.co/fXw9xYz https://ibb.co/wY0TYYQ

$\endgroup$
6
  • $\begingroup$ can u please provide blend file? are your normals ok? did you try to recalculate outside? $\endgroup$
    – Chris
    Aug 2, 2021 at 6:04
  • $\begingroup$ Please do not put external links in your question. You can edit your question and upload the images directly in there. $\endgroup$ Aug 2, 2021 at 6:28
  • $\begingroup$ easyupload.io/cb6o0i I have no idea. To be honest I am quite new to blender and have only been using it for a little over a week maybe 2 weeks. $\endgroup$
    – Blendmoth
    Aug 2, 2021 at 6:31
  • 1
    $\begingroup$ My answer was quicker than your upload... now that I have the file, I can't reproduce your error - is this the file from which you made the screenshots? Because your file doesn't even have a camera in it to render. When I add a new camera and render it, I don't get the result you showed here. $\endgroup$ Aug 2, 2021 at 6:37
  • $\begingroup$ i made same experience as Gordon: no camera. Cannot reproduce your error. Please upload exactly that blend file from which you made the screenshots. Thank you. $\endgroup$
    – Chris
    Aug 2, 2021 at 6:39

1 Answer 1

1
$\begingroup$

It looks like Z-figthing to me without seeing the file. If you take a look in the Outliner, there are objects set to be invisible in the 3D Viewport, but I guess they are visible in Render.

invisible objects

To get rid of those render artifacts you can either delete the invisible objects if you don't need them anymore, or you can disable them in Render. To do that, click on the Filter symbol in the Outliner window menu and enable the Disable in Renders button (the camera symbol).

disable in renders

Now these camera symbols are shown for each object and collection as well and you can disable the Render Visibility by clicking (just like you did with the Viewport Visibility).

disabled objects

$\endgroup$
5
  • $\begingroup$ easyupload.io/f9wgtk Sorry this is the current file with the camera added like I have now. $\endgroup$
    – Blendmoth
    Aug 2, 2021 at 7:00
  • $\begingroup$ I am still working on the texture and forming the shape right way. But here is also an example of what I am trying to recreate. ibb.co/KNtt7Jq Any sugestions, tips, or ideas how to improve my work are welcome as I am a total beginner at this. I have just been trying to use tutorials to create something of my own but I am still struggeling as you can see. $\endgroup$
    – Blendmoth
    Aug 2, 2021 at 7:05
  • $\begingroup$ Fixed the issue! It was indeed the duplicates that I forgot to turn off that was interfering with the rendering. $\endgroup$
    – Blendmoth
    Aug 2, 2021 at 7:18
  • $\begingroup$ @Blendmoth Please consider accepting so that users can see there is a working solution, read here: What should I do when someone answers my question? $\endgroup$ Aug 2, 2021 at 12:15
  • $\begingroup$ Thanks I couldn't figure out where either the vote up button or accept answer button was. $\endgroup$
    – Blendmoth
    Aug 3, 2021 at 0:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .