1
$\begingroup$

Why is the plane that is below another mesh showing through it? I have transmission and transparency set to 0 for the materials that are being shown through. When I hide the plane, the material renders fine. However, when the plane is visible, it completely shows through the laptop.

Any ideas why and how to fix it?

I am using Blender 2.93.1 with the Eevee engine.

Plane in viewport shows through laptop. enter image description here There does seem to be this sweet spot where it doesn't show through: enter image description here When plane is hidden, the laptop in the viewport looks fine. enter image description here When the plane is not hidden, the render also has the laptop be see through. enter image description here When the plane is hidden in the render, the laptop looks fine. enter image description here

The bacon is unaffected as is the keyboard which is coplanar to the plane.

Here is the solid view so you can see the plane is very much below the laptop and not intersecting it. enter image description here

Node setup for monitor screen: enter image description here Image texture used for monitor screen: enter image description here Node setup for terminal screen on laptop: enter image description here

I haven't been able to find any similar issues to this. Thanks for any help!

EDIT: @CoolCoder High Quality Normals did not do the trick. Thank you though. enter image description here @Chris Blender File

$\endgroup$
4
  • 1
    $\begingroup$ Try turning on High Quality Normals in Render Settings>Performance $\endgroup$
    – CoolCoder
    Aug 2 '21 at 4:46
  • 1
    $\begingroup$ can u please provide blend file? $\endgroup$
    – Chris
    Aug 2 '21 at 6:12
  • 1
    $\begingroup$ If it's EEVEE, you probably have "Alpha Blend" turn it on for that material $\endgroup$
    – Emir
    Aug 2 '21 at 14:31
  • $\begingroup$ @Emir That fixed the issue! Thanks. $\endgroup$
    – kaisa
    Aug 2 '21 at 17:21
0
$\begingroup$

The issue was the blending method for the plane. It had Alpha Blend turned on. I changed it to Opaque. Everything else has blending bode set to Alpha Blend. enter image description here

What it looks like now: enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.