2
$\begingroup$

It's my first time trying to rig a hand I created. I've set an armature in the hand, selected the hand first, then the armature, hit Ctrl + P and selected Armature Deform > With Automatic Weights. Based on the tutorial I followed to do this, it should've worked but when I go into pose mode, the hand doesn't bend with the bones. Can someone please help out?

The tutorial I followed for this: https://www.youtube.com/watch?v=KpokgpH1VvE

The blender file can be found here: https://drive.google.com/file/d/1yAz-vNTVgaiTC0DXteNm53078JF3_0s8/view?usp=sharing

I'm new to Blender, so to anyone answering: Would be kind enough to explain it in super-layman terms, please? Thank you!

enter image description here

$\endgroup$
1
  • 1
    $\begingroup$ Firstly I recommend opening the mesh in weight paint mode, and check the vertex groups in the object data properties. If you see the weights appear as you go through the vertex groups then you know your parenting worked. If you don't see them you now know that blender isn't building the weights for you, which will be the next issue to solve. $\endgroup$
    – James
    Jul 31 at 15:49
5
$\begingroup$

You have not enabled the bones Deform option for any of your bones, select all your bones in Edit or Pose mode, go into the Bone panel > Deform, put your mouse over the box and press AltEnter together and all your bones should now have the option enabled. Parent again. When you first parented, as the option was disabled, the bones didn't create any vertex group, now it will.

enter image description here

$\endgroup$
1
  • $\begingroup$ Much thanks! This worked! $\endgroup$ Aug 10 at 3:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.