0
$\begingroup$

I am creating animations for my game character and have thus far created actions for idle, run, dash, and sprint. However, I want to add a cloak to my character using blender's cloth physics and record the cloak's movement for each action. I have four cloth bakes in the cache (one for idle, run, dash, and sprint), but I am not sure how to "combine" each of the bakes for the corresponding action. I want to be able to export to unreal engine and have single animation sequences that include both the character animation and cloak animation. I may be thinking about this the wrong way, but I would like help on the how to solve this problem.

$\endgroup$

1 Answer 1

0
$\begingroup$

I can't comment yet (not enough rep) so i'll place my suggestion in an answer.

Firstly what game engine are you using? If it's UE4 then I have an alternative method for you below:

If you rig the cap with a simple skeleton (perhaps a few of bones on each side of the cape) and then import it into ue4 as a skeletal mesh you can run a really simple cloth simulation on you cape, like you might with a flag. Model your cape around your character as you normally would in blender, and the points that you want to keep solid so they don't flap around e.g. shoulders should be left unweighted when setting up your sim in ue4. For better clarity, give this a watch.

Once your cape is properly simulating, apply it to your character mesh in game, either with sockets, or as a skeletal component within the character blueprint. Now you get live, realistic(ish) fabric motion without the hassle of baking out extra anims.

Hope this helps.

$\endgroup$
5
  • $\begingroup$ Yes, I am using UE4. However, I am unable to troubleshoot an issue with the cloth not colliding with the capsule colliders of the physic asset. I've already made sure to apply all transforms to the model, scale was 1.0 when exporting from blender, and to use the tapered capsule for physic asset. Issue still persists. $\endgroup$ Jul 30, 2021 at 12:14
  • $\begingroup$ Did you set your units up correctly in blender? Should be at 0.01 metric, as blender works in metres, whilst UE4 works in cm. The units need to be set before you start any modelling though, so I recommend starting a new file, adjust your units, then import your mesh and rig, scale by 100 and apply the scale $\endgroup$
    – James
    Jul 30, 2021 at 13:00
  • $\begingroup$ I'm experiencing another issue following your solution. After starting new file > adjust units to 0.01 metric > import mesh and rig, the scale of the rig automatically became 100, and applying the scale deforms the rig and ruins the animations. $\endgroup$ Jul 31, 2021 at 4:54
  • $\begingroup$ @user12100564 are you appending from blender or importing an fbx? $\endgroup$
    – James
    Jul 31, 2021 at 12:57
  • $\begingroup$ I am importing a .fbx of the mesh and rig to the new file. $\endgroup$ Aug 1, 2021 at 2:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .