1
$\begingroup$

When rendering this project using my GPU and CPU I get incomplete shadows that show up as blocky. I have an AMD Radeon 5700 XT and AMD Ryzen 7 3800X 8-Core Processor. I've tried the following:

  • Rendering the project with just my GPU
  • Uninstalling and reinstalling Blender
  • Downloading an earlier version of Blender
  • Adjusting for the shadow terminator offset
  • Updating my graphics card driver
  • Uninstalling and reinstalling my graphics card driver
  • Rendering with just the CPU

The latter option fixes the problem, but at a huge loss to render time as I'm not using my GPU to help. When I'm rendering with the GPU it almost seems as if it's just giving up and moving to the next tile without finishing it. The same thing happens when rendering volumes, and this wasn't happening to me before. On the left is the render if I use just the CPU, the right is the same render if I use only the GPU, or the CPU and GPU together.

$\endgroup$
1
  • $\begingroup$ Did you tried to change tile size of render? In performance tab? GPU likes to render bigger tiles so maybe if you change it from default 64x64 to something bigger may work $\endgroup$
    – MikoCG
    Jul 30, 2021 at 7:09

1 Answer 1

0
$\begingroup$

AMD drivers have been having rendering and shading issues since updating their drivers. I had to revert to AMD's old update back in December of 2020 to solve this.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .