When I pan with the Shift + MMB, it doesn't work. I think I might have accidentally pressed some sort of key-shortcut. It works for other views, so it's not my mouse. What sort of shortcut could I have pressed?

  • If you say that it "works for other views", do you mean other views of the same Blender instance? Also, panning works with Shift + MMB, not Ctrl + MMB. – JulianHzg Aug 12 '13 at 11:03
  • If the problem is only for one 3D View space, and it's in perspective mode, this might help: Why does the zoom sometimes stop at a point?. That's because you said the shortcut is Ctrl+MMB which is for zooming. – Adhi Aug 12 '13 at 11:34
  • Did mean shift+mmb and edited post to clear of further confusion :) Works for other 3D view spaces in the same blender instance yes. I tried reloading Factory Defaults as dukejib suggested and it fixed the problem. Thanks :) – springbo Aug 12 '13 at 12:30
  • Somehow, unbeknownst to me, I had locked my view (Shift-Numpad .). I had to unlock it again (Alt-Numpad .) before Shift-MMB would work again. – asoundmove Sep 13 '17 at 15:09
up vote 2 down vote accepted

Not sure of the Shortcut. but you can get your original settings back by loading Factory Defaults. Its in File Menu.

I've had this happen a few times to me, and not pressed anything I shouldn't.

I found going to object mode and pressing the home key fixes it. (View All).

I seem to get this problem when I've zoomed in too close, or am using the UV view.

  • 2
    Fixed a problem for me, thanks! – Arek Dec 22 '15 at 16:49
  • 1
    I want to upvote this answer more than others. It’s unfair that I can’t. An underrated question following this answer specifically: here. – 7vujy0f0hy May 7 '17 at 10:27
  • 1
    As a reminder, you can just hit spacebar and type View all. – JLund Oct 1 '17 at 11:17

If reloading the factory settings in File>>Load Factory Settings helps, then you can check your mouse settings in the user preferences, input tab:

change rotate and pan

In the example, the checkboxes are set to pan with MMB and rotate with ShiftMMB.

If that's not the reason, it might be that you are in perspective mode and you have zoomed in a lot. Does the 3d view display 'Persp' in the top left corner? NUMPAD5 or holding NUMPAD- will repair that.

I had the same problem, and this solution worked:

  • Hit N in the 3D view to open the Properties region.
  • In the View submenu, turn off Lock to Cursor or Lock to Object.

It's not unlikely that a relatively inexperienced user would not realize that this setting exists, or would not know how to restore it.

  • Worked for me in my case, thanks! – Yann Masoch Feb 16 '17 at 1:37

The problem was solved by setting the daemon program "X Neural Switcher", well who would have thought!

Xubuntu 14.04: stop the daemon of "X Neural Switcher".

protected by David Oct 13 '15 at 0:49

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.