2
$\begingroup$

I am attempting to bake the chairs in a living room scene in Cycles using the "Combined" bake. When I apply that image texture to the chair it is MUCH too bright compared to a render of the same chair. What other types of bakes should I use and how would I combine them? The original chair uses a Wood.jpg image texture into a diffused shader mixed with a glossy shader. I've tried baking diffused direct, diffused color, and glossy, and MixRGB them together, but it looks even worse. Adding a brightness node & turning down the brightness looks bogus too. What am I missing?

Comparison of Render and Baked images Node editor

I'm adding some more info, but I don't consider this problem answered because what I came up with is a ridiculous kluge that's sill not quite right. I've tried so many things that at this point I don't think I can replicate all the bakes I'm using. The chair on the left is the one I'm trying to bake. In a nutshell:

Two slightly different 'combined' bakes are totally subtracted from each other which leaves shadows too dark & the color messed up. A color adjustment node (RGB Curves) corrects the color which is 'lightened' with a 'diffused color' bake to reduce the shadow from the table.

Like I said, not really a solution.

enter image description here

$\endgroup$
  • 1
    $\begingroup$ Looks like it could be a bug, but I notice that the emission shader you're using to view the baked texture has a a strength of 1.7. Is it still blown out at 1? $\endgroup$ – gandalf3 Jan 15 '15 at 21:18
  • $\begingroup$ Ha. I didn't spot that, but no, even turning the emission shader to .5 still gives me a washed out surface where you can't see any wood grain in it. $\endgroup$ – papabrewsky Jan 16 '15 at 13:56
  • $\begingroup$ By the way, that scene is nicely done, I really like the lighting and materials :D ! $\endgroup$ – GiantCowFilms Jan 19 '15 at 21:41
  • $\begingroup$ Well, I discovered the solution to my problem, which is similar to your problem, so I wonder if the solutions will be similar. The emission shader (that you have to use for the baked texture) can't imitate the roughness value of a diffuse shader (in my case), and that roughness aspect also can't be baked in. I wonder if there's some similar aspect of your original shader (probably something that depends on view angle) that just can't be replicated by the baked texture. $\endgroup$ – Matt Feb 27 '15 at 20:46
1
$\begingroup$

I can't be sure, but it seems entirely likely that your whites are getting crushed. I can guarantee that the white in your specular highlight on that chair is much higher than "255." But a typical image can only hold up to a 255.

Generically, this situation is handled one of two ways. Either, anything over 255 is just clipped/clamped to 255, or the whole range of values is crushed/scaled so that everything fits in a 0-255 range. This makes all the highlights darker because what used to be between 1000-2000 level of intensity gets scaled down to something like 150-250.

You situation would only be explained if Blender is doing some kind of intensity compensation that's tuning everything down so that your whites are crushed instead of just clipped. I don't know if Blender actually does that or not, but it'd explain what you're seeing.

I also don't know how to solve that, unless you can bake to an EXR or HDR that will record values higher than 255.

Hope that helps.

$\endgroup$
  • $\begingroup$ Nevermind. I misunderstood the problem. I thought the bake was too dark, not too bright. $\endgroup$ – Matt Feb 27 '15 at 19:33
-1
$\begingroup$

Try just using a diffuse shader for the baked texture. If it's still to bright try turning down the lights to about half the strength. When you're baking Blender factors in the lights in your scene. So when you're just exchanging the wood texture with the baked one there's basically double the light for just that chair.

What I meant with "double the light" is that when you're baking with the light source you'll later use to light the chair, the baked texture already contains that light info. I once had the problem you're having, figured that's what it was. Sorry.. Also I think I misunderstood. Your saying the baked image by itself is messed up? Not the image looks fine and only weird when applied to the chair? Maybe you changed a setting that's causing that? Have you tried using default settings?

$\endgroup$
  • $\begingroup$ Not sure why there would be 'double the light'. In this case the window sill was an emitter too, as well as the sun. Turning the lights down still doesn't give me a good bake. $\endgroup$ – papabrewsky Jan 17 '15 at 23:38
  • 1
    $\begingroup$ I'm not sure what you're saying. The reason for baking is to keep the material/texture from rendering, and that requires an emission shader. If I substitute a diffuse shader it defeats the whole reason for baking. $\endgroup$ – papabrewsky Jan 19 '15 at 18:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.