8
$\begingroup$

I was making a 3D eye and when I added a glossy material to the model, the light looks great, except for the fact that the model looks too dark. Is there any way to fix it? Maybe add a better material setup for it? (I need a fast/quick material, not a complex one, I have very little time)

enter image description here

$\endgroup$
  • $\begingroup$ Try adding a diffuse shader as well. And double check your lighting. $\endgroup$ – VRM Jan 15 '15 at 16:03
  • 3
    $\begingroup$ Make sure the color of the glossy is white. $\endgroup$ – Scalia Jan 15 '15 at 16:06
  • $\begingroup$ @VinceScalia Go ahead and add as an answer for the answer ratio $\endgroup$ – VRM Jan 15 '15 at 16:09
  • $\begingroup$ oookat. answering $\endgroup$ – Scalia Jan 15 '15 at 16:10
  • $\begingroup$ @NoviceInDisguise If he adds the answer UV. $\endgroup$ – GiantCowFilms Jan 15 '15 at 16:20
10
$\begingroup$

You can add a Diffuse shader to your material. The color of a Glossy shader is influenced by what is being reflected, so having a Diffuse shader underneath will make the color more consistent across the entire mesh, in all settings.

enter image description here

With a 100% white input, here were my results:

Just Glossy:

enter image description here

With Diffuse:

enter image description here

$\endgroup$
  • 1
    $\begingroup$ True, but he might just wan't his mesh to be that reflective, in which case this may not work... But it is nice to avoid having to create/find an HDR. $\endgroup$ – GiantCowFilms Jan 15 '15 at 16:19
  • 1
    $\begingroup$ Most objects are not 100% reflective anyways I have noticed. No matter what lighting, you can always tell the color of it. Especially something complex and organic like an eye. $\endgroup$ – VRM Jan 15 '15 at 16:20
  • 1
    $\begingroup$ I agree he should add a diffuse texture, but It is useful to have any degree of reflectiveness visible, which is more what the question is. $\endgroup$ – GiantCowFilms Jan 15 '15 at 16:28
  • $\begingroup$ True. I agree with that. $\endgroup$ – VRM Jan 15 '15 at 16:28
13
$\begingroup$

You need the change your background. It is currently reflecting the sky, wich is that dark grey color. I would recommend adding an HDR image To add reflections etc.

Without HDR:

enter image description here

With HDR:

enter image description here

No lights or materials were changed in the setup.

Adding A HDR Background:

enter image description here

Set the works "color" to environment texture. You may need to raise the strength to make it bright enough.

You can still have the grey background with a little hack if you need it:

Simply add these nodes to your world material.

enter image description here

Not-Ideal HDR work around In the case you don't have an HDR, you can use this workaround. The reflections will be less realistic, but it still works well.

Add these nodes to your world material:

enter image description here

Result:

enter image description here

$\endgroup$
4
$\begingroup$

Make sure that the color of the glossy shader is set to white, either with an external color node (as seen in @NoviceInDisguise's answer), or with the color setting in the glossy node itself.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.