0
$\begingroup$

Whenever I add a loopcut to a mesh and try to put another mesh through it, the face creates weird shapes like seen in the picture weird face shape with no geometry. I've never had this problem before.

It started when I imported a bunch of meshes from ZBrush. I began adding cubes around the meshes and when I got the base shape right I started adding more geometry by adding loopcuts. This is when I noticed that the faces of the mesh to which I added a loopcut created these shapes without geometry. After moving the vertices around I noticed that it almost looks like as if the face of the mesh with a loopcut was snapping to the object it was going through face seems to be snapping in a way. I checked that the snapping was disabled and made sure that auto merge is off as well, but the issue persisted. I opened a new blender file and all was working well. I assumed that It might have something to do with the meshes from Zbrush but once I imported them to the new file all was working fine. Then I opened a new file and the issue came back again. Now it is still present every time I open blender. The same happens when I try to add new geometry by using subdivision.

I tried restoring the preferences to factory setting, reinstalling blender, and applying all transformations in object mode before adding loppcuts but none of it worked.

Since these shapes contain no geometry, I assume that this is a rendering issue, but I have no idea how to fix it.

Any help would be appreciated. I'm still fairly new to blender.

$\endgroup$
0
$\begingroup$

So I tried to replicate your situation and I got this: enter image description here

Similar right? Also your problem is not in all those things you mentioned but in basic of how polygons work...

If you need for your objects to keep that shape you showed than you should try to select those faces or whole object and in edit mode use CTRL+T to triangulate faces... It will remove those clippings

enter image description here

It is simply caused by wrongly used 4gons. If you look at it from this view then it seems fine: enter image description here

But if you look from another angle you will notice a non existing edge that is trying to keep your mesh logical: enter image description here

Try to change the shape of those polygons that cause this and remember that all 4 vertices of 4gon must be flat... one of them out of place will cause these clippings

$\endgroup$
2
  • 1
    $\begingroup$ Wow, You actually took time to reply to some moron who mistook basic blender functionality for a bug. Mad respect. Like I mentioned above, I just got paranoid as blender spawned an asymetrical cube and I started seeing problems where they were none. Still, good to know that there are people like you, willing to explain everything to newcomers. $\endgroup$
    – user128601
    Jul 28 at 21:55
  • $\begingroup$ No worry my friend, we all started somewhere $\endgroup$
    – MikoCG
    Jul 29 at 9:08
0
$\begingroup$

Turns out I got blendered

The mesh I added somehow spawned asymetrical I kind of overreacted and started seeing things.

Everything is in order (with blender at least, I'm pretty sure I'm paranoid). I've seen blender do questionable things before but I didn't know it could troll this hard.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.