0
$\begingroup$

I am new to blender simulations and I am trying to create a simulation of a ball (active rigid body) falling freely and colliding with bunch of other objects (passive rigid bodies). During the simulation at certain frame I want to scale the ball and continue its motion (in simulation) with that new scale. I tried using animated flag and keyframes but it didn't work. Some of the technique that I tried and problems associated with them are :

  • Checked animated flag at the frame where I want the active body to be scaled and added keyframe. But when I check the animated flag the ball gets shifted to the original position (at the start of the simulation).
  • Scaled the active body at the frame where I want the active body to be scaled. Then added scale keyframe. But when I scale the ball, it stays at that position even if I play the simulation from start.

I am sure there is a simple work around for this but I couldn't find the solution.

$\endgroup$
2
  • $\begingroup$ Shall the ball scale in free fall or during its interaction with other rigid bodies? $\endgroup$ Jul 28, 2021 at 8:35
  • $\begingroup$ During interaction with other passive bodies. In my case the ball bounces on 2 passive objects and I want to scale ball after it bounces from fist passive body and before hitting other one (in the air). $\endgroup$
    – raiKage
    Jul 28, 2021 at 9:12

2 Answers 2

0
$\begingroup$

I found that using keyframes on the scale factor without the animated checkbox worked.

The animated toggle works as a binary flip between rigidbody physics that does not follow location or rotation keyframes and following the animation which does not follow rigidbody physics (but still can collide with objects).

$\endgroup$
2
  • $\begingroup$ At first it didn't work with my test file and gave weird results. I then tried it with animating the Delta Transform Scale which worked perfectly. Trying again with normal Scale gave weird results again - and then Delta Transform didn't work anymore either. But setting up everything completely new suddenly made it work in each variant. But it's really frustrating how sometimes deleting rigid body bakes doesn't have any effect at all. I wonder if there is no setting to get completely rid of the old cache. $\endgroup$ Jul 28, 2021 at 10:05
  • $\begingroup$ @common grey can you please explain it in the steps. Because as mentioned in the question, when I scale the active rigid body (anywhere during the simulation) it stays at that frame even if I play the simulation from start. $\endgroup$
    – raiKage
    Jul 28, 2021 at 16:30
0
$\begingroup$

Ok so I have solved the problem. Thanks to @common grey and @Gordon Brinkmann, I was able to play around with different types of keyframes and managed to achieve desired the effect. I am adding link to a .blend file with sample simulation. Here's what I did :

  • I am using cube as active rigid body and a plane as passive rigid body.
  • I first enabled animated flag for cube and added a keyframe, because I wanted it to start falling down at specific frame. So at frame 20 I disabled animated so that the cube starts falling.
  • Then on frame 44 (totally random number) I added keyframe for scale (Hit i and select scale). This will be starting point of scaling of cube.
  • On frame 56 I enabled animated flag (which shifts the cube at starting point - this might throw you off at first but its totally fine) then scaled up the cube and added a keyframe for visual scale. This is where cube stops scaling up in the simulation.
  • Again I did the same for scaling down the cube.

Thank you.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .