8
$\begingroup$

For some reason objects don't show their transparency all the time.

In this image the circles in red are suposed to be transparent like the ones in green.

enter image description here

When I select the object in the back, all objects in front of it become opaque.

enter image description here

When I select the two objects that are opaque, then they become transparent as they sould be.

enter image description here

The display is in GLSL mode

These are the material and texture properties

enter image description here

enter image description here

I'm not worried about the final render, just the editing view. I would like to see the actual transparency at editing time only, because the scene is to be imported in a third party game engine.

Blender is v2.68

This is the blend file

$\endgroup$
7
$\begingroup$

Go to the object panel in the properties and check Transparency in Display tab for all object you want to see transparent. make sure that you have the correct object selected.

transparency option

$\endgroup$
  • 1
    $\begingroup$ I tried this, and while it does work, if you set multiple objects to display transparency there will be some strange things of certain objects being occluded and others not. (It all seems to depend on what object is selected) $\endgroup$ – gandalf3 Aug 12 '13 at 18:13
  • $\begingroup$ @gandalf3 I'm finding this now, similar as you've described, with unselected objects appearing correctly partly obscured behind partly-transparent objects, when selected, the portion of the object behind the partly-transparent front object is entirely occluded. Weird. Using 2.74 $\endgroup$ – Tom Pace Apr 17 '15 at 15:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.