1
$\begingroup$

I am trying to do pwnisher's community challenge. I downloaded base animation template (Blender). In blender the animation is playing just fine but when I add new objects for collision (rigid body : passive), the falling ball passes through it. Here are some settings that I'm using :

Ball :

  • Rigid body type : active
  • Collision shape : sphere

Cube :

  • Rigid body type : passive
  • Collision shape : mesh

I want the ball to collide with the cube. I tried dropping a object on other objects in another blend file and it works fine (I tried adding new objects and saw if those collide). I am totally new to simulations in blender. What could be the problem ?

.blend file : https://drive.google.com/file/d/14Ial5rG_0nimY8lnwLZTknmjENt2FtPb/view?usp=sharing

Solutions I've tried so far:

  • Tried deleting all bakes.

  • Tried changing steps per second from 10 to 60.

  • Tried applying scale to the newly added cube (ctrl+A).

$\endgroup$
2
  • $\begingroup$ Hi. As it stands it is not answerable for lack of essential details to understand the issue. Remember only you have access to your scene, so unless you describe it thoroughly only you know your exact setup, settings and what steps you took to arrive where your are now. Please illustrate in detail what your issue is, possibly supported by some accompanying screenshots with the edit button above. $\endgroup$ Jul 26 at 11:43
  • $\begingroup$ @DuarteFarrajotaRamos thanks for replying. I'll add link to the blend file. I'll also edit the question and add solutions I've tried so far. $\endgroup$
    – raiKage
    Jul 26 at 11:47
1
$\begingroup$

The solution does not work for 2.82

  1. Select your ball, and in the timeline delete all keyframes (so the physics can do its work).

  2. uncheck the "animated" flag here:

enter image description here

  1. go to scene properties: hit "delete all bakes" in rigid body world

  2. for your ball change sensitivity -> collision margin to 0

enter image description here

run the animation

you get this:

enter image description here

$\endgroup$
8
  • $\begingroup$ Hi @Chris. Thanks for explaining in easy steps. But in 2nd step after deleting all keyframes the animated flag is already unchecked. I followed all the steps but still facing the same issue. Do you think there's a problem with my blender settings ? $\endgroup$
    – raiKage
    Jul 26 at 12:50
  • $\begingroup$ Please start by downloading the file from your google drive. If you follow exactly my steps - it should work. Which Blender version are u using? $\endgroup$
    – Chris
    Jul 26 at 12:57
  • $\begingroup$ I did download the file again and follow your steps. Still no luck. I'm using Blender v 2.82. $\endgroup$
    – raiKage
    Jul 26 at 13:03
  • 1
    $\begingroup$ Sure I'll update it. I just wanted to know that if its a bug or something was wrong with my settings. Thank you. $\endgroup$
    – raiKage
    Jul 26 at 13:23
  • 1
    $\begingroup$ Your settings were all good - for me it looks like a bug, because with these changes i described above it worked for me. $\endgroup$
    – Chris
    Jul 26 at 13:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.