1
$\begingroup$

Dear gardian angles from stackexchange,

I am working with Blender 2.82 and Unity 2017. I know that it is a common problem that .blend files of a higher version cannot be read by Unity. Apart from trying out different .fbx export and import settings. I tried the following:

  1. Exporting my project from blender to Unity as .fbx. This results in a spiked object.Spiked elbow when importing .fbx into Unity

  2. The .fbx file looks normal when I import it in Blender 2.82 and also in Blender 2.79.

  3. Saving this .fbx file as .Blend file using Blender 2.79 cannot be read by Unity either (while normal .blend files from 2.79 can). Symbols shown in Unity 2017

  4. In blender, the normals look normal (in Edit mode with an extended arm)

enter image description here

How can I import an .fbx file in Unity without the spiked elbow?

Thank you in advance!

$\endgroup$
0
$\begingroup$

It's looks like a bone limit issue for me. Try to set a different value (more than 1 bone) in Skin Weights in Edit -> Project Settings:

enter image description here

$\endgroup$
1
  • $\begingroup$ Wow, that easy and it works, thank you so much! :D $\endgroup$
    – Laura
    Jul 23 at 13:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.