1
$\begingroup$

TL;DR The Blender video sequencer memory usage climbs and climbs to a total of 40/50GiBs (RAM+Swap, I presume) until Blender crashes.

It is impossible to render the entire sequence.

I am using Blender 2.92 for a simple video and picture compilation.

It utilises 8 tracks - two for sound (one allocated to the music, another for sound imported from the video clips themselves) - I call them 'video clips' but they are in fact quite large and high resolution.

Several cross-fade transitions are used, necessitating the use of an extra track to facilitate that, along with layers allocated to speed control. At one point, two videos are overlain over each other, both with speed controls, plus Gaussian blur on one track, and a text track, taking the total track utilisation in that section particularly to all eight tracks, whereas for most of the video the average track utilisation is three.

I'll attach a screenshot to illustrate (music track is not visible):

Blender 2.92 Sequencer

Concerned about the high memory consumption, I checked Blender preferences, where I can ascertain that the 'memory cache limit' is set at 4096 MiBs (4.0 GiBs), which is no issue for the workstation I use which has a total of 16GiBs of physical RAM.

Blender 2.92 Preferences

Also shown are some of my working specs - an RTX 2060, which certainly is not underpowered for the job, itself having 6.0 GiB of memory.

For safe keeping I even set a limit on the disk cache (32.0 GiBs).

Enter now proof of my issue, where peak memory reads as 47'440.05 MiBs of memory:

enter image description here

I am struggling to understand why my memory usage here is so high, or what options to adjust to prevent this.

I have 25% resolution proxies generated for the videos when not rendering, making the preview sharp and responsive. Blender causes no issues except during the render.

I suspect somewhere along the rendering pipeline, memory is not being released and consequently accumulates until Blender cannot allocate any more memory. The 'MEM' and 'Peak' numbers (shown) keep climbing as the VSE progresses through the frames.

For completeness I'll show some more settings from the 'Properties' top, not comprehensive, but showing that the 'workbench' renderer is selected in case 'Eevee' or 'Cycles' were culprits (they seem not to be, although why would this affect the VSE anyway?).

enter image description here enter image description here

(The 3D scenes contain simple text but with glossy and glassy materials to enrich the introductory scenes. 'Simple' VSE text channels are also used, not to be confused with each other).

Thank you for your time and help.

$\endgroup$
1
  • $\begingroup$ Maybe you should try a copy of your project in 3.0, to check if the issue has been addressed already? $\endgroup$
    – tintwotin
    Jul 22 at 21:16
1
$\begingroup$

Discovered the offending VSE tick-box, inside the 'speed control' effect strip:

It seems enabling 'Frame Interpolation' causes memory to leak. Disabling it eliminates this.

Hope this saves further headaches.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.