enter image description here

Context: I am doing an interior render for a store concept. I am working on a 1:1 ratio.

This is my scene right now. Before I added the "Room 1 Installation" collection (which is in the furniture piece on the far left where the buddha statue is), my file size was around 140mb, somehow now the file size is 1.3GB and I can feel that its lagging. Could it be because of the number of meshes I have created? I didn't want to join them together because I was trying to have it non-destructive.

Edit: I also tried selecting all vertices and merging by distance, but it didn't affect the size that much (around 100mb).

*Also in another copy I deleted all the things I added since my file size was around 140mb, and surprisingly the file size is still 1.1GB now

Any thoughts or suggestions?

Edit #2: I found out that the strings that are supposed to attach the yin yang above the bonsai plant, took up to 600mb. Those were just a simple cylinder and I had subdivision solidifier applied to them.

Wireframe View: enter image description here

I tried deleting these high poly objects in different copies of the project and I found out that the bonsai plant or even the rock dont affect the size that much. The statue definitely makes a difference (if I delete it, the file goes to about 140mb). I'm fairly new to blender and still have a lot to learn. I'm going to look into the decimate modifier

  • 1
    $\begingroup$ You can check if the Buddha statue is extremely high-poly. Is it a scanned model? Then you could try to remesh it. Or does it come with a lot of high-res textures? Then you can replace them with resized versions of the same texture. $\endgroup$
    – michaelh
    Jul 22, 2021 at 9:23
  • $\begingroup$ @michaelh I would say 90% of the meshes in the file are made out of cubes. I just learnt to link the similar ones together but It doesn't affect the file size that much (maybe a few mb). I tried delete the Buddha statue but it did only take about 100mb. $\endgroup$ Jul 22, 2021 at 10:34
  • $\begingroup$ Many of the objects look very high-poly. The tree, the rock and the shelves with the grid-like walls for example. Quite likely you can use the "decimate"-modifier on these quite heavily to reduce poly-count without losing details noticeably! If that does not work satisfactorily, please show us a wireframe view of your scene so we can identify the "troublemakers" more easily! $\endgroup$ Jul 22, 2021 at 11:24
  • $\begingroup$ Have you tried the options in the File > Cleanup Menu? Maybe there is unused data lying around. (Meshs Datablocks will stay around until you restart Blender or Cleanup manually) If you use Remesh- or Decimate-Modifiers, remember you'll need to apply them to affect the file size. Bc otherwise the original mesh will still be there. $\endgroup$
    – michaelh
    Jul 22, 2021 at 11:29
  • $\begingroup$ Also, the oval-ish things at the bottom of the image look unnecessarily highly detailed. When using the decimate-modifier, please be aware that for it to have an impact on the saved filesize, it needs to be applied. For performance however, the effect should be immediate. $\endgroup$ Jul 22, 2021 at 12:00


You must log in to answer this question.

Browse other questions tagged .