Every time I select a bone in Pose Mode, none of my keyframes show up but my animation still plays. So far I've tried changing/clicking in the "View" menu of the "Timeline" editor...

  • Disabling/enabling "Only Keyframes from Selected Channels" -- When disabled it only shows my shape keys.
  • Disabled "Only Show Errors"
  • Hit "Frame All" multiple times (which is "View All" in my case.)
  • Hit "Go to Current Frame"

I've also tried in the "Timeline" editor...

  • Scrubbing up and down holding down middle click
  • Zooming in/out of my timeline
  • Checking "Summary" but below it shows nothing

The only time Blender will show my keyframes is when I go to my Hair Bones Layer with it's baked Wiggle Addon data and my Shape Keys. Bones that control the head, fingers, hands/etc do not have their keyframes visible no matter what I try. Before all of this happened, I was able to see all my keyframes until I had enabled an addon known as "Wiggle Bones" and baked it onto my hair.


My goal is to have my keyframes visible again for bones such as the one which controls the head. Any help? :, D

  • 1
    $\begingroup$ maybe you've pushed your action in the NLA? If it's not the case, please share your file (at least the armature): pasteall.org/blend $\endgroup$
    – moonboots
    Jul 21, 2021 at 17:26
  • $\begingroup$ What do you mean by I "pushed my action in the NLA?" $\endgroup$
    – someone
    Jul 21, 2021 at 17:39
  • $\begingroup$ Also, heres my file: drive.google.com/file/d/1sWkqhqga5xi6QvSWXd0CgglJ0VIoHog2/… $\endgroup$
    – someone
    Jul 21, 2021 at 17:40
  • $\begingroup$ I can't reproduce this problem in the file you made available for downloading. $\endgroup$ Jul 21, 2021 at 17:46
  • $\begingroup$ Oof well it's okay now since someone already found the answer to my issue so no worries ovo $\endgroup$
    – someone
    Jul 21, 2021 at 17:53

1 Answer 1


As you can see if you open the NonLiner Animation window, you've pushed your action into it (the yellow strip we see). Now open the Dope Sheet window, switch it to Action Editor mode. You can either select the yellow strip, press Tab in order to bring back the action, or select it in the dropdown menu.

enter image description here

Remember that if you press on the Dope Sheet Push Down button the action will play in the NLA but it won't be available in the Dope Sheet anymore, this is what probably happened here.

  • $\begingroup$ Oh I understand now $\endgroup$
    – someone
    Jul 21, 2021 at 17:51
  • $\begingroup$ Thank you! This actually fixed my issue, I'm able to edit/see the keyframes again!! :D $\endgroup$
    – someone
    Jul 21, 2021 at 17:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .