1
$\begingroup$

I have been following BlenderGuru's Doughnut tutorial and since I am new to Blender I am unable to figure out as to why the Doughnut mesh keeps clipping through the icing mesh.The first render pass of the doughnut was absolutely fine until I was completing the "Part 5 : Level 2: Final Doughnut" video.enter image description here

As the image stated above it looks completely normal in both the Layout mode and Lookdev mode until I swtich to a Render View and I get this :

enter image description here

I did try pulling the vertices of the icing out with soft selection but apparently it messes up the geometry even more.Help a newbie out here will ya?Thanks!

$\endgroup$
1
  • 6
    $\begingroup$ It looks like in the viewport, you are looking through Material Preview (which doesn't show true displacement). In your render, the displacement of the mesh is causing it to protrude through the icing. Try turning down your displacement strength, and if that doesn't work/makes it look too flat, you may need to scale up your icing slightly, or move the affected areas manually. $\endgroup$ Jul 21, 2021 at 7:50

2 Answers 2

1
$\begingroup$

Click the icing part and go to the solidify modifier. Make sure that camera icon is enable before clicking the render button. That works for me.

$\endgroup$
1
$\begingroup$

Make sure that your subdivision surface modifier are both set to the same levels, if the viewport levels are different than the render levels then you will see quite noticeable changes when you try to render.

subdivision surface

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .