0
$\begingroup$

If you look on the left rails there is some weird black shading? (im using blender cycles) If you look on the left rails there is some weird black shading?

$\endgroup$
6
  • 1
    $\begingroup$ Try adding sharps to the ends of the rails (Edge mode, select, right click, sharp) and resetting the normals vectors $\endgroup$ Jul 20 at 12:32
  • $\begingroup$ Are you using the Cycles rendering engine? $\endgroup$
    – Nogard
    Jul 20 at 12:32
  • 2
    $\begingroup$ It can have multiple reasons. Please share the material node tree $\endgroup$
    – Gorgious
    Jul 20 at 12:39
  • 2
    $\begingroup$ ...or share blend file $\endgroup$
    – Chris
    Jul 20 at 12:41
  • $\begingroup$ Yes I am Using The Cycles Engine $\endgroup$
    – Forest
    Jul 20 at 12:53
1
$\begingroup$

This is a common issue with Shade Smooth. The normals on the sides are being interpolated to the face on the non-camera-facing side, and so the rendering engine is reporting it as a lost ray because it reflects into the background or otherwise runs out of light bounces before it can find a light.

You can see a recreation of the issue in this example scene.

enter image description here

Two simple ways to fix:

  1. Enable Auto Smooth in Object Data Properties -> Normals.

enter image description here

enter image description here

  1. Create some supporting loops on the ends to decrease the area over which the interpolation happens.

enter image description here

enter image description here

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.