0
$\begingroup$

I can't seem to figure out why it shows a black box in 3d viewport. I followed a quick liquid tutorial and I used a quick liquid function from the F3 menu, after changing the liquid from geometry to inflow it looked nice and so I went over to the 3d viewport and it's all just a black box. I tried putting lights and re-baking it but nothing worked.

This is how it looks in 3d viewport:
this is how it looks in 3d viewport

And this is how it looks in wireframe mode:
and this is how it looks in wireframe mode

I don't know how to reply to the guy who commented on me so I'll just put the domain material here:
material

$\endgroup$
4
  • 1
    $\begingroup$ You have baked no mesh, there is only fluid data as particles. And what about your domain material, can you add a screenshot too? This complete blackness looks like you have no shader nodes or anything. $\endgroup$ Jul 19 at 14:15
  • $\begingroup$ provide your blend file so we can check it out $\endgroup$
    – Chris
    Jul 19 at 15:01
  • $\begingroup$ @Chris mediafire.com/file/j6gwgerr1qhkr4j/quickliquidhelp.blend/file $\endgroup$
    – Moogle
    Jul 19 at 15:20
  • $\begingroup$ Is this the correct file? You said you changed Geometry to Inflow, but the file still has a fluid object set to Geometry. And on my system it doesn't look black. But as I said before, you haven't baked the mesh - so whatever you do to make it not look black anymore, it will still look like a cuboid and not a liquid if you don't bake the mesh. $\endgroup$ Jul 20 at 10:01
1
$\begingroup$
  1. if you follow a tutorial and you are a bloody beginner you SHOULD exactly follow the tutorial because every little step is important and cold ruin your whole simulation

  2. as i could see in your blend file ...you didn't follow the tutorial at all...

  3. to get "something" change these settings:

  • change cache type to "replay"

enter image description here

  • change viewport shading to material preview

enter image description here

then you will get:

enter image description here

$\endgroup$
3
  • $\begingroup$ ohhhh thank you very much <3 $\endgroup$
    – Moogle
    Jul 19 at 19:01
  • $\begingroup$ You are welcome $\endgroup$
    – Chris
    Jul 19 at 19:35
  • 1
    $\begingroup$ Please consider to accept the answer @Moogle How this site works: blender.stackexchange.com/tour $\endgroup$
    – brockmann
    Jul 20 at 10:16
0
$\begingroup$

About the blackness here. That's a bug in Blender 2.93 when Roughness value is set to a very low value (0.003...) and you have an Intel UHD Graphics unit or another affected GPU.

In Blender 2.92 it looks as it should:
liquid domain in Blender 2.92
liquid domain in Blender 2.92 with Roughness set to 0.000

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.