3
$\begingroup$

I have used Blender for a while but I just cannot figure out how to fix this topology problem. After using a Boolean modifer, my topology was fine I thought until I viewed in render mode. enter image description here

I know it is because of the two edges selected, but I just can't find a way to get rid of them and keep the boolean shape there. I've also attached the .blend file:

$\endgroup$
2
  • $\begingroup$ you can't avoid these edges, you need edges to create a hole within a face, and it doesn't seem to cause any problem in render mode (or does it?) $\endgroup$
    – moonboots
    Commented Jul 18, 2021 at 19:57
  • $\begingroup$ Gotcha. But for some reason they are causing the faces to glitch. I attached the blend. file if you want but in the image you can see it caused those weird distorted reflections... $\endgroup$ Commented Jul 18, 2021 at 20:15

1 Answer 1

5
$\begingroup$

You can't avoid these edges, you need edges to create a hole within a face, and it doesn't seem to cause any problem in render mode.

For your shading problem: You've shade smoothed your object, so it tries to smooth the shading between perpendicular faces, and it gives these artefacts. What you need to do is enable the Auto Smooth option and lower down its value under 90° so that it only smooth faces that are under 90°:

enter image description here

$\endgroup$
1
  • $\begingroup$ WOW! It's perfect now, thank you so much! $\endgroup$ Commented Jul 18, 2021 at 20:30

Not the answer you're looking for? Browse other questions tagged .