2
$\begingroup$

When using mmd files the animation ends up warped. What could be done to fix this error?

frame 1 Frame 1: model looks right warped animation

All other frames: model looks warped

$\endgroup$
  • 1
    $\begingroup$ Looks as though your face indexes are messed up. How do you create the original model? If it is an OBJ try using the "Keep Vert Order" option. Then use mesh cache modifier on the imported object to apply the MDD file. $\endgroup$ – beiller Jan 12 '15 at 19:03
3
$\begingroup$

Keep Vert Order needs to be on when using mmd in Blender to avoid warped geometry.

Workflow:

  1. File >> Import >> .obj, on right options, turn on Keep Vert Order vert order
  2. Select imported object
  3. File >> Import .mmd
$\endgroup$
  • $\begingroup$ It should have been @beiller posting the answer, since you didn't know it, and he told you how... $\endgroup$ – someonewithpc Jan 12 '15 at 21:58
  • $\begingroup$ @someonewithpc we can't force beiller to write an answer, at least the op took the time to do this. $\endgroup$ – Neil Jan 13 '15 at 8:33
  • $\begingroup$ Hehe go ahead and accept. I don't know how to post screen shots yet so cred! $\endgroup$ – beiller Jan 13 '15 at 19:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.