0
$\begingroup$

I'm sure this question has been asked before, but I have literally no idea how to describe it (or I'm simply the first to ask; I really don't know). I was trying to animate the "Rain" Cloudrig doing a backflip (using the blocking technique) and for the most part succeeded. However, when I switched back from constant to bezier, some of the bones, such as the head and pelvis, rotated in random direction before settling into the next pose. Here's a quick video showing my issue:

https://www.youtube.com/watch?v=FbEpsL-aX4U

Due to this, I had to go and fix the poses myself, which added even more keyframes for me to deal with. This issue makes things harder for me in the graph editor, makes the animation look very weird and choppy since it no longer follows a smooth motion, and once again the sheer amount of keyframes doesn't seem ideal. For future projects, how could I avoid this and save some time?

$\endgroup$
1
$\begingroup$

Try to check your frames on graph editor. Try to change easing, handle type to automatic or auto clamped, as well as "smooth keys alt+o" and "Discontinuity (Euler) Filter" - they are available in graph editor, top bar menu "Key"

$\endgroup$
1
  • $\begingroup$ Thank you so much! I'm so glad I know about the discontinuity filter now, it really helped! $\endgroup$ Jul 19 '21 at 5:37
0
$\begingroup$

When you switched from constant to bezier, the two sides of the bezier handle became effective. However each side is rotated now affects the animation. Unlike constant that stays on one value until it reaches a parameter and goes immediately to the next value. Linear moves from one value to another like a vector, it finds the quickest path between handles.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.