2
$\begingroup$

These weird lines

I imported an object from maya and created a material in blender...and when i turn on the alpha blend option i get these wired lines every time. I already tried flip normals ,recalculate normals , shade smooth , alpha hashed but these lines are still there

I want to export the file in glb format from blender and these lines are still showing up there
Here is the link for blender file

https://we.tl/t-OGJRmYd7JW

$\endgroup$
4
  • $\begingroup$ I tried following your instruction and got good result in blender Thanks.... but when exported in Glb format these are still visible. $\endgroup$ Jul 14 at 6:28
  • $\begingroup$ Is this render engine problem or what? $\endgroup$ Jul 14 at 6:29
  • 2
    $\begingroup$ Glass in Eevee needs tweaking, if you remove the Show Backface it will fix your problem but you won't see your own object by transparency, I hope someone has a proper answer $\endgroup$
    – moonboots
    Jul 14 at 6:39
  • 1
    $\begingroup$ a hack would be to create a second object for the inner surface of your object, see Bibi's answer here (french, donwload his file): blenderclan.tuxfamily.org/html/modules/newbb/… $\endgroup$
    – moonboots
    Jul 14 at 12:45
1
$\begingroup$

So I'm not sure there's any perfect solution for your problem, but here is a trick proposed here by Bibi.

If you disable the Show Backface option you'll get rid of the artefacts that you're talking about but you won't see the glass surfaces by transparency, so you still have a problem:

enter image description here

The trick is to separate your glass object in two separate objects, the outter and the inner surfaces...

enter image description here

and you'll get that, which is rather good:

enter image description here

the file is available here:

$\endgroup$
1
  • $\begingroup$ Thank you so much this method solved my problem.... $\endgroup$ Jul 15 at 3:42
0
$\begingroup$

change the blend mode of your material to alpha hashed.

Then you will get:

enter image description here

$\endgroup$
3
  • $\begingroup$ I changed the mode to alpha hashed and exported it in glb format(as i need glass object in Glb format) But these lines are still there $\endgroup$ Jul 14 at 5:28
  • 2
    $\begingroup$ you didn't write anything in your question that you do export your file, and nothing about glb format. So you should improve your question....! $\endgroup$
    – Chris
    Jul 14 at 5:29
  • 1
    $\begingroup$ Thanks for the suggestion.... I improved my question $\endgroup$ Jul 14 at 5:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.