6
$\begingroup$

I've already had question according array modifier. I had changed object alignment from 'Align To: World' to 'Align To: View' in the 'User Preferences'. It's because i wanted to add objects in 'Front Persp' and spare me rotation steps i every time take when i'm adding a new object. After changing it i ended up having problems with modifiers relative offset properties, i had to tweak the 'Y' axis to move it up and 'Z' axis property to move it in the direction where normally 'Y' axis would be. So the question is: is it possible to add objects in 'front ortho' without messing up the axis of the object?

$\endgroup$
4
$\begingroup$

No, you either get it aligned to your current view, including the object's local orientation, or globally oriented.

Apply object rotation

Go to Object Mode and press Ctrl+A, 2 (Apply Rotation) and your object orientation is applied, meaning that the mesh stays exactly the same but all 3 axes are parallel to the global ones afterwards.

Concerning default behaviour

You can't make blender apply the rotation of your object all the time or always when you add an object.

I guess it would be possible to write a python addon/macro to always realign the axes for you after adding an object, but someone else would have to help you with that.

Other workaround

You can add any object first from top view (Numpad 7), delete the mesh (X) and re-add the mesh you want from the perspective you want (e.g. front with Numpad 1, Shift+A). This will only add the mesh within the already correctly aligned object. Which is not really a lot faster than the method mentioned above, sadly.

Third (probably best) workaround

Go to top view (Numpad 7), add the object, go to front view (Numpad 1), press F6, (disable and)* re-enable "align to view", this re-aligns the mesh to the current view without altering the object orientation.

  • only if align to view is enabled by default
$\endgroup$
  • $\begingroup$ Great!! it does work but could short explain why? Did i just rotated objects orientation to have it aligned with global orientation? because the object itself does seem to stay untouched. $\endgroup$ – orustammanapov Aug 11 '13 at 9:10
  • $\begingroup$ and is it possible to set it as default behavior? $\endgroup$ – orustammanapov Aug 11 '13 at 9:13
  • 1
    $\begingroup$ It basically rotates the objects to be aligned to the global coordinates, and then rotates the mesh back to where it was before from a global point of view, so both the orientation of the object and the position of every point within the object change, but globally, the mesh stays where it was. -- See also: wiki.blender.org/index.php/User:Fade/Doc:2.6/Manual/… -- I added a comment on the default possibilites above, but there is no ideal solution. $\endgroup$ – JulianHzg Aug 11 '13 at 9:19
  • $\begingroup$ I added a third workaround that's probably even better, partially based on sambler's answer. $\endgroup$ – JulianHzg Aug 11 '13 at 11:49
2
$\begingroup$

The option to align to view or world is available to each object added. Pressing F6 after adding an object gives you the operator options, which is also visible at the bottom of the tool palette by default. Among the options you have for a newly added object is Align to view, if turned off it is aligned to world.

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.