0
$\begingroup$

I figured out the problem to my last question with the help of someone else and I successfully changed the bones from FK to IK. But now that it’s working, the leg glitches at some parts when I imported a motion. It works just fine when I move it in pose mode have linked pictures below and a blend file, and I’d also like to point out that I am on blender 2.8 using the render engine eevee. Thank you in advance.

How it’s supposed to look (yes I am using the same model again because she is the only one out of all the other models this person made that works well):

enter image description here

What it looks like:

enter image description here

Blend file: https://drive.google.com/file/d/1ZzMOVdW7vfMENaA4cqfwf81jjeMmAke1/view?usp=sharing

$\endgroup$
3
  • $\begingroup$ Are there any constraints on the armature(rotation etc)?...they normally cause such kind of glitching $\endgroup$
    – starzar
    Jul 12 at 2:16
  • $\begingroup$ @starzar How would I check that? $\endgroup$
    – uvennaa
    Jul 12 at 2:42
  • $\begingroup$ @starzar Oh, like limit rotation? Then yes, I do because it needs it. If I remove it, then it's even worse than before, + it does not fix the glitching unfortunately. $\endgroup$
    – uvennaa
    Jul 12 at 2:48
0
$\begingroup$

Constraints on the armature(rotation etc) normally cause such kind of glitching.

The effect of the constraints can be limited by setting the minimum and the maximum values .

enter image description here

$\endgroup$
4
  • $\begingroup$ I actually think I am getting closer thanks to you, I'm looking at a model that works and what numbers she put in and I tried those but it unfortunately didn't work, so right now I'm kinda testing all the numbers. Do you have any recommendations? I am only using limit X. $\endgroup$
    – uvennaa
    Jul 12 at 3:37
  • $\begingroup$ First disable the constraint (eye icon) to confirm if it because of the constraint and if so ,only then tweak the values. $\endgroup$
    – starzar
    Jul 12 at 4:02
  • $\begingroup$ Alright, it is the issue. Sorry one last thing, would this fully remove the glitching or just minimize it? $\endgroup$
    – uvennaa
    Jul 12 at 4:16
  • $\begingroup$ Glitching is caused because of the constraint values set ...they have to be tweaked (min/max)depending on the model to completly remove it .Check which axis is causing the glitch and then tweak only those values. $\endgroup$
    – starzar
    Jul 12 at 4:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.