1
$\begingroup$

How do I make it so when I press Tab in sculpt mode I go to object mode?

I press Tab in sculpt mode and it goes to edit mode. No matter what I do Tab is a combo of edit mode and any other mode. To go to object mode from sculpt mode I have to go to the dropdown menu every time. I want to get rid of edit mode from sculpt or just make it so Tab goes between sculpt and object mode. Any help with this stupid problem would be greatly appreciated.

$\endgroup$
1
  • 1
    $\begingroup$ That is normal. I honestly would like it if there was such a function, but this is normal. $\endgroup$
    – TheLabCat
    Jul 10 at 2:21
3
$\begingroup$

Hi Joey !! You can follow Emir`s method or you can follow this one. Just in case you find it annoying to press tab and then 4 again and again if you want to open sculpt mode then follow this one ;)

STEP 1: Edit>preferences>keymap>check the option 'tab to open pie menu' (as Emir said)

enter image description here

STEP 2: The quickest way to set a shortcut key in Blender is to right-click the operator(in your case the operator is sculpt mode) you want to set a shortcut for it so select 'Assign Shortcut' now press the key combination you want as a shortcut for that operator(eg. C)

enter image description here

enter image description here

enter image description here

NOTE: the key that you will press will be your future shortcut for sculpt mode. You can't assign it with a shortcut like 'tab' 'ctrl' or 'shift'.I would recommend the shortcut to be one of the alphabets eg.'S'('S' for sculpt mode as it so easier to remember). Also if you move your mouse away from the 'assigned shortcut' option then it will disappear.

How do I check whether I have assigned my shortcut?

you can ensure by selecting the dropdown menu and beside sculpting mode, your desired shortcut key should be there in grey text.

REMEMBER STEP 1 MANDATORY

I hope this answer adds up to something useful and is comprehensible for you

enter image description here

How to reset a shortcut key in Blender?

You can reset a shortcut key in the user preferences. Go to Edit->Preferences and find the keymap section. If a shortcut has been changed from the defaults, a restore button will appear just above the shortcut key on the right side in the user interface. Press it to restore the operator to its default hotkey.

enter image description here

$\endgroup$
4
  • $\begingroup$ I appreciate the responses! Two quick questions on the shortcut thing; 1) what if i press s to go into sculpt mode but then when i press tab to go to object mode, it takes me to edit mode once again?(i think my main problem is I cant get tab to be a combo back and forth of sculpt and object). and 2) how can I see what keys arent assigned to anything so that i make sure im not overwriting something important? thank you :) $\endgroup$
    – Joey N
    Jul 10 at 10:55
  • $\begingroup$ Your welcome :) joey happy to help. I know you have a few questions in mind, for the first one I have an answer that you may be interested in, but you cant press Tab to travel to object mode and back to sculpt mode, unfortunately. Shall I post another answer as an alternative for pressing tab to travel back and forth as that is not possible(I think) or are you better of without it? ;) $\endgroup$
    – Ribbit12
    Jul 10 at 13:12
  • $\begingroup$ sure id be happy with any solution so i dont have to keep using the dropdown lol $\endgroup$
    – Joey N
    Jul 11 at 1:12
  • $\begingroup$ Ha Ha Ha 😁😁 ok great! $\endgroup$
    – Ribbit12
    Jul 11 at 4:23
1
$\begingroup$

One option that you could use is CTRL + Tab to open the pie menu and then 4 to switch to object mode

enter image description here

There is also an option under Edit > Preferences > Keymap... To use only Tab to open the pie menu and then you just need to press 4

$\endgroup$
1
$\begingroup$

Hi again! so I have a pretty simple answer in mind but I am not sure you will be satisfied by it. Now let me answer both your questions!

So, basically, you just need to repeat the same process of assigning a shortcut to an operator but in this case, you want the operator to be the object mode. I am going to carry on this answer by assuming that you have assigned a shortcut for sculpt mode (if you haven`t then please do).

1) What if i press s to go into sculpt mode but then when i press tab to go to object mode, it takes me to edit mode once again?(i think my main problem is I cant get tab to be a combo back and forth of sculpt and object).

enter image description here

you should have something like this**(after assigning a shortcut to object and sculpt mode)**

Now you can easily alter between both the modes by just pressing O and S or any two key combinations!!

or you can go to the dropdown right click on object mode and sculpt mode and select the 'add to quick favourites' option.

enter image description here

now press Q on your keypad so that the 'Quick favourites menu' can show up and both the modes should be there.

enter image description here

2) How can I see what keys arent assigned to anything so that i make sure I'm not overwriting something important?

There are two answers to this question. You can either go edit>preferences>keymap>3d view

enter image description here

or you can try experimenting by pressing various shortcuts on your keyboard and check whether the shortcuts have an operator and perform an action or not.

Hope this answer was useful!! :)

$\endgroup$
1
$\begingroup$

If all you want is to switch objects when in sculpt mode, all you have to do is to hover your mouse over the object and press D. The new object now will be the new focus for the sculpt mode.

If you want a quick way to alternate between the two, then Ribbit12's approach is spot on.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.