4
$\begingroup$

I have a super simple Particle system. I am instancing a sphere (Render->Object->DupliObject->Sphere) with a white emission material. When I set the viewport to render everything shows up fine, when I hit F12 nothing shows.... WHY?

I don't have any postprocessing enabled in the rendersettings, and I tried to cache the particles, but nothing so far...
Any ideas?

Here is a simplified scene that shows that behaviour

I could create a new system in a fresh scene, and append it into my main scene. So the problem is not related to the rendersettings.

$\endgroup$
  • $\begingroup$ There are many possible causes, could you upload your .blend file to Pasteall.org/blend for us to look at? $\endgroup$ – VRM Jan 10 '15 at 20:39
  • $\begingroup$ I added the link to a samplescene to the mainpost. $\endgroup$ – knekke Jan 10 '15 at 21:53
6
$\begingroup$

This is because the particle emitter is hidden in the render:

enter image description here

Particles inherit the object level properties of the emitter, so hiding the emitter object will hide the particles.

To exclude the emitter from the render without hiding the particles, disable Emitter in Particle settings > Render:

enter image description here

This is already disabled in your file.

To hide the emitter in the viewport without hiding particles, see Is it possible to hide particle emitters in the viewport without hiding particles?.

$\endgroup$
  • $\begingroup$ This is so embarrassing.... I was sure I checked that more than once. Sorry for wasting your time! Thanks! ...But why doesn't this affect the viewport render? $\endgroup$ – knekke Jan 11 '15 at 11:44
  • $\begingroup$ @knekke Viewport render still uses viewport settings. I guess the rational was to be consistent, and not to use potentially really slow settings (lots of subdivisions, many hair particles, etc.) in the real-time render. $\endgroup$ – gandalf3 Jan 11 '15 at 22:46
0
$\begingroup$

Your parent object (the particle) must also be on the same layer as the emitter.

$\endgroup$
0
$\begingroup$

I realize this answer is a bit late but I need to share that when making a fireball scene I didn't add a material to my emitter. This was the deciding factor in me seeing my Particles and not seeing them.

I believe you can still make it so that the emitter isn't seen by clicking the camera button in your outliner with the emitter selected.

Here's the fireball with out any particles. They appeared however after giving a material to my emitter The second image has the emitter with a material

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.