0
$\begingroup$

I'm quite new to Blender but have been trying to render a design for a keyboard. I was able to produce something like:

enter image description here

note, the blues and the grey of the floor. This was rendered using the menu (ie. render>render image (f12)). However, as I was updating my objects, something must have happened that has changed the colour of everything in the renders. Now, everything is coloured like:

enter image description here

Note, the blues and greys are now totally different, and the lighting seems to have changed. I don't believe the properties of the objects have changed, and the actual hex codes of the colours are definitely the same. The problem persists even if I render through Z render and even when I access Material Preview via Z as well. If I copy everything into a different file, everything reverts back to the original, correct, colour scheme.

I don't even know where to begin trying to debug this. Can anyone please help me?

A commenter suggested I share the .blend file - it can be located here

$\endgroup$
4
  • 1
    $\begingroup$ It's hard to tell. Are the images screenshots from the viewport or render outputs? Which shading mode is active (key Z)? $\endgroup$
    – Blunder
    Commented Jul 8, 2021 at 22:25
  • $\begingroup$ These are from render>render image (f12). However, there is a similar effect from going either Z Rendered or Z Material Preview $\endgroup$
    – Andrew
    Commented Jul 9, 2021 at 9:01
  • 1
    $\begingroup$ if you provide your blend file - we can check it out $\endgroup$
    – Chris
    Commented Jul 9, 2021 at 9:13
  • $\begingroup$ thats very generous, its at we.tl/t-rqEHH7tHio - I feel I should note, that I'm quite new to this, so I'm sure I've got a lot to learn and I can see myself what I've done is a little messy.. ha.. Its weird as the colour (while it is wrong) is consistent throughout all of this .blend file. If you transfer an object out though it reverts to its "true" colour.. $\endgroup$
    – Andrew
    Commented Jul 9, 2021 at 9:19

1 Answer 1

1
$\begingroup$

Somehow I managed to change a color management setting was incorrect.

I fixed this by setting Scene Properties > Color Management > Display Device to sRGB

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .