4
$\begingroup$

I'm messing around with the Barcelona Pavillion demo scene. When I enable the viewport render, no textures are appearing in the viewport render, the objects are just grey:

enter image description here

However, when I render the scene all the textures are properly assigned. Why is this?

$\endgroup$
2
4
$\begingroup$

In the View Layers panel > Override, remove the selected material, otherwise you'll make it the only one showing for all your objects:

enter image description here

$\endgroup$
0
$\begingroup$

in the "viewport shading" view normally there are no textures. This is default behaviour (there are exceptions). If you want to see textures, change to

  • material preview enter image description here

or

  • rendered view enter image description here

The "solid" viewport display is made for building/moving/creating things and good performance. That's why textures aren't shown because they tend to make the computer/visualization slower.

$\endgroup$
5
  • 1
    $\begingroup$ Yes, but I'm in the "render view' mode, using cycles. Normally, I can see textures in this view, but for some reason, I cannot on this file. $\endgroup$ Jul 6 at 6:23
  • $\begingroup$ ok, that's weird. I can see it...what version are u using? $\endgroup$
    – Chris
    Jul 6 at 6:24
  • $\begingroup$ The most recent version. 2.92 I think. I'm pretty sure It's a setting specific to this file, as none of my personal .blends do this. $\endgroup$ Jul 6 at 6:33
  • $\begingroup$ Ok, that’s even more weird. Did you try to download the file again? Maybe you changed something unintentionally? $\endgroup$
    – Chris
    Jul 6 at 6:44
  • $\begingroup$ No, I believe this is just how the author made it. Must be a setting somewhere. Anyway, I was just curious. Thanks for the help anyways. $\endgroup$ Jul 6 at 6:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.