1
$\begingroup$

I am making a gun that shoots lasers so I am keyframing the visibility to turn on and off. The problem is when the object is disabled in the viewport, I can no longer see the keyframes in the timeline. This makes it especially hard to adjust things since I cant see when the bullets turn on and off exactly.

I could just keyframe the rendered view but that makes it even more trickier because bullets could be showing in the viewport but not in the render. Having a bunch of bullets lying around the scene also makes it difficult to know what exactly is going on or if the gun is even firing. Having a point light attached to the laser that must also have its light enabled/disabled complicates things even more.

$\endgroup$

2 Answers 2

1
$\begingroup$

If you are using the Graph Editor, you can disable Show Only Selected and enable Show Hidden, this way you can see the keyframes of hidden objects. The same applies in the Dope Sheet Editor.

keyframes of hidden object

$\endgroup$
2
  • $\begingroup$ That sort of works. But it reveals all keyframes in the scene which populate the viewers making it very difficult to work with when you have a complex scene. $\endgroup$
    – Mike
    Jul 5, 2021 at 16:16
  • $\begingroup$ @Mike Sure, otherwise you would need another toggle setting for each object, visible in graph editor or invisible in graph editor (which you actually have). If you have too many objects and are not willing to do that manually on all of them, I'd go with Chris' method. As he said, if you have just one material for the laser there's only one thing to manipulate. $\endgroup$ Jul 6, 2021 at 5:53
0
$\begingroup$

Why don't you just animate the materials alpha? and instead of changing from 0 -> 1 (which you can do at last step) you animate from .3 to .7. So you still "see" everything in the viewport and you can still differentiate between "on" and "off" and you can still work with keyframes. If you are satisfied with the result you just change the alpha value from 0 -> 1. And since the "laser" materials are "normally" just 1 or a few you don't have to change a lot.

$\endgroup$
2
  • $\begingroup$ For some reason alpha values aren't working for me. when I set alpha to 0 on a material it renders the laser as solid black $\endgroup$
    – Mike
    Jul 5, 2021 at 19:07
  • $\begingroup$ you have to set blend mode in material Settings to Alpha blend or hashed $\endgroup$
    – Chris
    Jul 5, 2021 at 20:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.