0
$\begingroup$

Newbie to Blender here, running Blender 2.9. I'm following a tutorial to create a city, but getting stuck on applying a textured material. It's only coming out as a solid color. So far I've tried...

Here is the shader graph I have on mythology material:

Shader graph

And here is how the material is showing up on the model:

Model

$\endgroup$
5
  • $\begingroup$ Try changing from Point to Texture in the Mapping node $\endgroup$ Jul 4 at 17:59
  • $\begingroup$ Are your meshes unwrapped? Are your meshes being created by modifiers, like Geometry Nodes? $\endgroup$
    – Nathan
    Jul 4 at 19:20
  • $\begingroup$ @DuarteFarrajotaRamos Unfortunately it had no effect $\endgroup$ Jul 4 at 19:20
  • $\begingroup$ @Nathan Textures are indeed unwrapped (via "smart UV unwrap") and meshes are not generated (I don't think) they were imported from a map file $\endgroup$ Jul 5 at 1:00
  • $\begingroup$ Then I suppose I'd need to see a file to tell you what's going on (other than the fact that the mapping node you're showing isn't doing anything.) With a packed image. $\endgroup$
    – Nathan
    Jul 5 at 1:09
1
$\begingroup$

I found the solution and it was stupid. Not only did the texture need to be scaled down, it was coming in rotated at 90 degrees for some reason. Which, due to its imagery, made it just look like a solid color.

Lesson for next time: don't just play around with location and scale settings on mapping, do rotation as well!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.