1
$\begingroup$

I have been following along with Blender Guru's Donut tutorial. I reached the end of Level 3 Part 4, but I seem to have a persistent problem - the shadows on my cup and plate are way too dark. I initially thought it was because of my camera angle/light placement, then I thought it was a problem with the liquid but after hiding it from view, I see that it was neither.

Here's what I have done:

  • restarted the whole cup process, followed along with the same videos to ensure I didn't miss anything.
  • changed glossy and transmission bounces to 128, 64 and rendered with no changes.
  • deleted the glass material and tried setting it up again.
  • moved my scene light far away and changed its power/radius.
  • checked that my plate and cup are not intersecting.

What I have figured out is that when I elevate my glass and plate above the plane, the transparency of the materials seems fine, and matches BG's results. But when I set it nearer to the plane, it darkens.

The Guru's results.

dark areas in reflection

elevated glass from plane

So I'm guessing it must be something to do with the plane, but changing material of the plane, and setting it back to no-material also yields the same results.

Note: in my blend file the BG camera and BG light are what I made to set the scene to mimic Blender Guru's lighting/camera angle to make sure it wasn't my composition giving me skewed results.

Thanks in advance <3

$\endgroup$
3
  • $\begingroup$ The other thing I notice from the pictures is that you've got highlights on the rim of the saucer and the bottom of the inside of the curve of the handle, while he does not, and this difference is in both of your renders. $\endgroup$
    – jwrush
    Jul 3 '21 at 18:28
  • $\begingroup$ @jwrush Do you think this could point to somewhere my modeling may have gone wrong? I went back to my blend file and made sure that the edge loop at the rim of the saucer and the handle aren't skewed in some way, but couldn't see any glaring messups. I also went back to the youtube video and his also seems to have the same highlights, just a bit harder to spot because of the pink plane, I think. $\endgroup$
    – jchalber4
    Jul 3 '21 at 18:39
  • $\begingroup$ Playing around with your blend file, I can change the color very close to his pink and I'm still getting them more vividly than in the screen shot. I also don't think it's a modeling problem, because I can distort the cup drastically and the shadows don't really change. My best guess is that it's either lighting, the glass material, or render settings (all of which I know you've checked a ton, and all of which look reasonable to me, though I've never done the tutorial) $\endgroup$
    – jwrush
    Jul 3 '21 at 19:01
4
$\begingroup$

You've limited the Max Bounces of the light to 6. The default value is 12. Fewer bounces mean faster render times (1:01 vs 1:12), but more noise and darker (glass) materials. Reset the value to 12 and your cup will look much brighter.

In your provided file the Denoising Data was not generated. You need to enable it in the View Layer Properties tab and connect the nodes in the compositor.

glass cup

$\endgroup$
1
  • $\begingroup$ This was it, thank you so much! I guess I must've changed it at some point and I glossed over it because having 6 min light bounces under advanced and and 6 max bounces in the light paths didn't stand out as a problem. I did have denoising enabled before but I even tried turning it off to see if that was the cause somehow. Thank you again! $\endgroup$
    – jchalber4
    Jul 4 '21 at 16:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.