Let's say I have 3 cubes attached and I need 2 renders from above. enter image description here

The first render should be square and aligned exactly to the size of a middle cube. There is no problem with it. I set the resolution to 1080x1080 and zoom in. enter image description here

But the second render I want to have Y resolution the same with X resolution bigger to contain all 3 cubes. It's logical that I should just increase X resolution. But when I do so it makes the rendered area SMALLER not bigger! enter image description here

What I need to do now is to move camera up by Z axis and have a painful guessing game trying to catch the same number of pixels for my geometry on both renders.

I added the red rectangle in the middle to make it more visual. What I'm trying to achieve is to have the same number of pixels for this red rectangle on both renders. It's important for me as I plan to use PNG images with transparency as layers in another software so the scale should be perfectly matched.

enter image description here

The way I fix it right now (make render, send it to Photoshop, see if I need to zoom in or out to match the scale and make it again) is very annoying and time consuming...

So I'll be very grateful for any help or advise!

  • 1
    $\begingroup$ Hello :). I think @Duarte will know how to do this using orthographic camera. You can hit him up in the chat ;) $\endgroup$ Commented Jul 1, 2021 at 22:01
  • $\begingroup$ @Jachym Michal thanks! not sure I have a chat option though.. $\endgroup$ Commented Jul 2, 2021 at 7:00
  • $\begingroup$ Hey :). Simply join our main Renderfarm chat chat.stackexchange.com/rooms/8888/the-renderfarm $\endgroup$ Commented Jul 2, 2021 at 8:11
  • $\begingroup$ @JachymMichal thanks I did! by the way I can't understand why my mention of a @ name doesn't work... $\endgroup$ Commented Jul 2, 2021 at 10:54
  • $\begingroup$ I think you can only mention people in chat who were participating in that chat room before. Anyway see if blender.stackexchange.com/questions/64914/… helps with camera scale $\endgroup$ Commented Jul 2, 2021 at 22:39

1 Answer 1


Default sensor fit is "Auto" - modifying output resolution only affects the smaller sides:

You can go to your camera settings to change the sensor fit to "Vertical":

Related: How to set specific sample spacing (meters in between each pixel) for a Blender Cycles Render

And a great thorough explanation by Gordon Brinkmann here: Why does reducing Resolution X increase my camera's FOV and increasing it reduce FOV?

  • $\begingroup$ wow it's great! thank you very much! can you please also clarify what width and height under Sensor Fit represent? $\endgroup$ Commented Jul 2, 2021 at 18:41
  • 1
    $\begingroup$ @LiliaLilia both a human eye and a camera sensor are not points - they have area. In case of a camera, the sensor is typically rectangular (I don't know of a circular sensor but I imagine some could be created for some scientific purposes). Since Blender already deals with quite a few effects simulating taking a picture (like depth of field), it makes sense to allow to specify camera sensor dimensions. $\endgroup$ Commented Jul 2, 2021 at 18:50

Not the answer you're looking for? Browse other questions tagged .