0
$\begingroup$

As you can see I have the face select option active, and yet I have found that I have a lot of edges with dots on them and when I select the dot and press X and delete face then the dot goes away and nothing else gets affected.

The dots are not the issue. I realize that when I use the face select tool, then the dots will only appear in the center of every face to demonstrate that is a face. But there are somehow tiny faces that blender has found that appear to be right on edges.

So for some reason, I have a lot of very tiny basically nonexistent faces that were made, and I had no idea how. I am individually selecting them all and deleting them because I have found it has caused me issues when doing some stuff with that object.

So my question I ask is there an easier way to select all those very tiny faces and delete them all at once.

screenshot

$\endgroup$
16
  • $\begingroup$ From the menu at the top of the 3D viewport (with your object selected in edit mode) try Mesh > Clean Up > Delete Loose. $\endgroup$ Jun 29 at 20:54
  • $\begingroup$ When I did that, it just deleted 4 faces that were supposed to stay and it didn't even touch the ones I'm having issues with :( $\endgroup$ Jun 29 at 21:05
  • 1
    $\begingroup$ Yeah. I see it. It looks like you have some messed up topology in that area. Inside the cube, if you look at the "outer" ring of the magnet, there are duplicate faces - there are some unattached edges too, but if I select them to delete, it takes stuff you want with it. Unfortunately, I don't have the time to get into the full details of it now, but I suggest a full re-work. I'll try to give it another look later when I have time, but hopefully before then, someone else can show you how to fix it. Unfortunately, it doesn't seem there is a "quick and easy" to fix this one. $\endgroup$ Jun 29 at 21:43
  • 2
    $\begingroup$ You mean the fact that faces centers (dots) that are right on an edge. Ok, I see... Yes, that's because you have duplicated vertices. Do a merge By Distance and the dots on the edges are gone. Enable Auto Smooth to fix the shading. But as Christopher Bennett already mentioned you have also a lot of flipped and overlapping faces. Turn on the Face Orientation overlay (red/blue) and check the inside of the box, especially the circles. There is some mess. $\endgroup$
    – Blunder
    Jun 30 at 0:25
  • 2
    $\begingroup$ Yes, this is what I mean. Turn on Face Selection mode with the dot overlay. You will notice that there are 2 faces, the small blue one, and a bigger, flipped, red one that overlaps it. Just select and hide/delete the big one and you will see what's going on. The faces are basically connected to the same edge and overlap. That's bad. You need to clean it up, delete the unwanted faces. $\endgroup$
    – Blunder
    Jun 30 at 0:47
2
$\begingroup$

Here is a summary of the comments.

1. Duplicated Vertices
The first issue, the "hidden invisible tiny faces", which this question is about, are caused by duplicated vertices. If you active the face center overlay (Center), a little dot is shown for the center of each face. You can see them in Edit mode when you active Face Selection (3) mode.

The problem is shown by the fact that there are some face centers (dots) exactly in the middle on one edge, marked yellow in the screenshot. These faces have some width but a zero-length.

screenshot with overlays

The fix for this is easy. Select everything (A), and press M, and choose Merge By Distance. Additionally, you need to enable Auto Smooth to get a clean shading.

2. Holes In the Mesh
If you have activated the Face Orientation and switch view mode (Z) to Solid, you will see there are some holes in the mesh. The outside of the cube should be blue, the inside red.

You can use the F key in Edit mode to fill the holes. Use Edge Selection* (2) to select the edge.

For larger holes enable the "Mesh: F2" addon in File > Preferences. Then you can create a squad face when you just select 1 vertex in the corner. Make sure you are in Vertex Selection mode (1). Then confirm (left-click) or cancel (right-click/Esc) the drag mode after the new face is created. Doesn't matter what you click just don't accidentally move the newly created vertex.

fill the holes animation

3. Overlapping Faces
There is a large flipped red circle (N-gon) that covers the underlying mesh. I'm not sure if you need it (is it a cover with transparent material?). If you want to keep it, make sure it gets flipped (blue).

If you peek in there you will see that the walls of the round structure have 2 edge loops that overlap with the narrow outer edge of the sticking out rim. You need to fix/recreate these walls/edge loops. Then you can use (Alt)+(N), Recalculate Outside and Blender should be able to fix all the flipped faces.

overlapping edge loops

$\endgroup$
1
  • $\begingroup$ Thank you. That helped a lot visually seeing it. And I couldn't figure out how to fix the holes I created by accident, so I went back to a previous backup model. Luckily I duplicate each stage and hide it in case I need to go back I won't have to start from the beginning. $\endgroup$ Jun 30 at 11:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.