3
$\begingroup$

I have this scene:

![enter image description here

The pillow is with Cloth physics (pressure=5), and the ball is with Collision (not a rigid body).

But when I start the simulation, it ends up with:

![enter image description here

As you can see there is a gap between the ball and the pillow. Where did it come from? The ball is not a Rigid Body, so there isn't sensitive margin.

If I make the ball a Rigid Body, it will simply clip through the pillow:

enter image description here

$\endgroup$
3
  • $\begingroup$ can you provide blend file? $\endgroup$
    – Chris
    Jun 26, 2021 at 5:45
  • $\begingroup$ @ChristopherBennett Thank you, it works! $\endgroup$ Jun 26, 2021 at 6:00
  • $\begingroup$ Hey, no problem. Turns out I've been using a very old way of making pillows for quite some time. Your way works in 5 seconds. Thanks for "enlightening" my old ways ;) $\endgroup$ Jun 26, 2021 at 6:05

1 Answer 1

7
$\begingroup$

In your collision settings, make sure Thickness Outer is set to 0:

Thickness

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .