0
$\begingroup$

I'm trying to take my entire rig by the root bone and rotate it while preserving all of its other bones' positions/sizes/rotations. It all works, except for the arms which start bending all over the place when I rotate the root bone. In the following gifs, I'm rotating the root bone around the z axis which moves all of the control bones (including the poles) perfectly. However, something is making the arm bones bend when they should be staying the same. The pole bone is moving with the others perfectly which leads me to think I may have messed up a setting with the IK bone constraint in the arm. But after playing around with those settings, nothing seems to solve the problem. The only other possible issue I could think of is a parenting issue, but like I said, the pole moves with the rest of the rig. It's just the mesh deform bones that are not matching it somehow. It all works perfectly until I rotate the root. I've also tried rotating all the other bones via a median point, but I get the same issue with the deform bones mysteriously moving. I also included images of the poles' settings and the arms' IK bone constraint settings.

I was following a YouTube tutorial series when trying to learn more about inverse kinematics. Here's a link to the specific video that went over the arm's IK properties if you're curious (and yes, it is in Japanese):

https://www.youtube.com/watch?v=2sSLzoPieoo&ab_channel=mmCG%E3%83%81%E3%83%A3%E3%83%B3%E3%83%8D%E3%83%ABanimetic

I'm new to inverse kinematics and all that stuff, so if you see any other issues, please do let me know. Thanks for the help!

Rotating the entire rig via the root - right arm Rotating the entire rig via the root - left arm

bone constraint

elbow pole

$\endgroup$
1
$\begingroup$

It can be a matter of parenting. Select the armature and go into edit mode. Check to see if the IK control bones are properly parented. To do this, select the bone and go to its Bone properties. In the Relationships section, check the parenting:

looking at parenting

In this example I have a bone that isn't parented. To fix that, select the bone, shift select the root bone, and type CTRL-P. This will bring up the make parent menu:

make parent menu

In that menu select "keep offset".

EDIT: This time it turned out to be drivers, I'm glad you found it

$\endgroup$
2
  • $\begingroup$ Thanks for the response! I double-checked the parenting again like you mentioned and everything was parented correctly, but while checking them I noticed that the upper arms were inheriting rotation from multiple bones because of a driver. All I had to do was uncheck the inherit rotation and let the driver handle the rotation instead. You led me down the right path to find the issue, so thank you so much! $\endgroup$ Jun 26 at 0:21
  • $\begingroup$ I'm glad you found it! $\endgroup$ Jun 26 at 0:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.