3
$\begingroup$

I am struggling to find a cause for the lack of transparency while rendering movie clips.

I have some green screen footage. In the compositor I have added the movie clip and a keyring node. Selected the eye dropper and in the viewer node it is showing as expected, however when I render the image the green screen is gone but I’m left with a black screen where it used to be with no transparency.

Masking still images and composing them isn’t a problem and I get the desired result but I can’t figure out why when I’m trying to do it with a movie clip it’s different.

All the colour settings are rgb, the transparency is turned on, I’ve got the file path saving to my desktop in an FFmpeg format. It plays back fine, the render quality is good but for the life of me I can’t figure why it won’t show transparent. Can anyone point me in the right direction?

$\endgroup$
4
  • 1
    $\begingroup$ Hello :). So, your rendered video won't show transparency? That's normal, not many codecs and media players support that. You might be better off rendering into an image sequence. $\endgroup$ Jun 23 at 19:45
  • $\begingroup$ Argh jeez that doesn’t sound great. I’ll try the image sequence and post back here when I’ve tried it $\endgroup$
    – Piid
    Jun 23 at 20:25
  • 1
    $\begingroup$ Sure :). Rendering animations as an image sequence has considerable benefits. Regarding a format, I'd suggest *.EXR if you want to composite the result. $\endgroup$ Jun 23 at 20:35
  • $\begingroup$ The video sequencer way does work, thank you. Also I found that you can set your codec formats in the encoding section of the drop down. This also works. $\endgroup$
    – Piid
    Jun 23 at 22:09
2
$\begingroup$

The reason the background does not show as transparent because by default RGBA is not an available option.

You can render a transparent video image straight out of the compositor workspace. I took a simple 250 frame scene loaded in a movie clip node and attached a keyring node.

Compositing Workspace

As you can see on the right hand side RGBA is now available. Blender by default has Matroska as a container, I changed this to MPEG-4 and RGBA became available to select.

I then downloaded the MP4 as an image plane and the result is as desired. By importing it as a plane and selecting emit I also have shadows and reflections. @Jachym's suggestion for the video sequencer and PNG files also worked and is what led me to this way.

Image as planes

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.