3
$\begingroup$

I'm completely new to Blender. I am trying to smoothen out the arc. however when I'm using the Shade smooth or Subdivision surface modifier, the whole shape crashes. is there a way to smoothen out the arC? enter image description here

$\endgroup$
1
  • 2
    $\begingroup$ it won't smooth on the inner faces because you have too many edge loops and they tend to flatten the faces, you should try first to X > Limited Dissolve (see the parameters in the Operator box on the bottom left of your 3D view), then shade smooth, then Properties panel > Object Data > Normals > Auto-Smooth $\endgroup$
    – moonboots
    Jun 21 at 21:33
4
$\begingroup$

Sorry, I've gone a bit nuts, and this answer has turned into an essay. If you just want a suggestion on how to model your arch, jump to the TLDR, below.

Smooth shading:

Roughly speaking, smooth-shading works by:

  1. Triangulating the mesh
  2. Calculating vertex-normals by taking an average of the normals of adjacent triangles
  3. Linearly interpolating the shading-normals between the vertex-normals, across the triangles.

These averages and interpolations may be weighted in various ways, but the principle remains the same.

The interpolated normals may be very different from the normals of the underlying geometry, yielding weird-looking results:

Behind your back, the renderers are doing this:

enter image description here

The illustration also shows the vertex-normals. As you can see, where faces meet at 90 degrees, the averaged vertex-normals stick out at 45 degrees. The shading normals are interpolated between those vertex-normals, across the triangles, which is not the same thing as the normals of the underlying faces, at all.

This is especially apparent when large, thin, triangles are interpolated across right-angles between faces. This is partly why N-gons are best avoided, except within entirely flat areas.

By switching on Autosmooth, in the object's Data tab, Normals panel, you can split the normals, per-face, preventing interpolation of normals where faces meet at greater than a threshold angle:

enter image description here

.. which can be an instant 'fix'. But the result can be unnaturally flat. (The material, here, is the same as the one in the previous illustration.)

The normal-interpolation is strictly between adjacent faces. So a Bevel can ease the interpolation of normals between large faces, by inserting small intermediate faces. If the profile of a 2-segment bevel is 1, (so the new faces are coplanar with the old ones) the interpolation is still between normals at right-angles, but restricted to the small bevelled area:

enter image description here

  • Top Left: No bevel.

  • Top Right: Bevel, 2 segments, shape 1, pretty much the same result as Autosmooth, but with a glint on the edges.

  • Bottom Left: Bevel, 3 segments, shape 0.75. You can soften the bevel quite some way. Adjusting the shape can make the normal-interpolation across the original, large, faces more reasonable.

  • Bottom Right. Subdivided. Bevelling won't necessarily rescue you from the entirely different problem of how Catmull-Clark subdivision creates new faces, and where it puts new vertices.

Subdivision

Making topology suitable for subdivision is another subject.. but a few rules of thumb:

  • Don't give Catmull-Clark faces with concave outlines to subdivide. The algorithm will usually place new vertices outside the faces altogether.
  • For the same reason, avoid narrow triangles, sharp angles at 'poles', where more than 4 edges meet.
  • After 1 level of subdivision, all your faces will be quads, anyway, so, if you're at a low-poly stage of modelling, n-gons in generally flat or near-flat areas aren't too harmful, but try to model with all-quad topology with squarish faces wherever possible. Blender's selection and modelling tools are geared to working with loops and rings of quads, so your life will be easier,too.
  • Try to keep the density of faces even across the model. If you need higher densities in some areas, try to make the transitions smooth.

TLDR;

To model this way, you need some sort of even transition from the semicircular arch to the rectangle that surrounds it. One possible route is this:

enter image description here

  1. Starting with a subdivided plane, select inner vertices
  2. X > Dissolve the vertices, leaving the perimeter subdivided
  3. Face menu > Poke the face
  4. CtrlShiftB Bevel the central vertex
  5. J join the vertices across the middle
  6. X > Delete unwanted faces
  7. EY (or whatever axis you're working on) Extrude the bottom edges straight down
  8. Select the new long edges, and Edge menu > Subdivide them
  9. Select all faces, and E extrude, or use a Solidify modifier.

Then the model is suitable for a Bevel of its sharp edges, either CtrlB by hand, or by using a modifier, and a level or two of Subdivision.

enter image description here

$\endgroup$
1
  • $\begingroup$ Dunno why step 5 is in there.. forget that one.. $\endgroup$ Jun 22 at 18:53
2
$\begingroup$

Let's say that you have this arch:

enter image description here

To shade smooth, right click and choose Shade Smooth. The result will be horrible as it will try to smooth between large perpendicular faces, so what you need to do next is go into the Properties panel > Object Data > Normals and enable Auto Smooth in order to define which faces will be smoothed.

enter image description here

Note that the profile won't be rounded though, you need more geometry if you want a round profile, in that case you need to subidive with a smooth value of 1, but it won't work fine, it will round everything unless you've sharpened your angles with additional edges.

The problem with your current topology is that you must have tried to round with subdivisions, but you didn't do the right way, so now it has a lot of faces that are coplanar, so instead of rounding the surface, it will tend to flatten it, even with the Shade Smooth and Auto Smooth. A lot of faces can round a surface if the faces are not co-planar, which is not the case here:

enter image description here

A way to fix your problem is to dissolve the co-planar faces with X > Limited Dissolve, you can tweak the angle in the Operator box if necessary, then give your object Shade Smooth and Auto Smooth and it should work.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.