2
$\begingroup$

i'm new in Blender. Can you guyz help me. I'm putting UVmapping to Lego character face. But the red and white color not appearing. Only black color just Like this. Can you guyz tell me how to show in color UVmapping ? Thank youenter image description here

$\endgroup$
1
5
$\begingroup$

Your node setup is incorrect (or we lack informations on why you did it like that). First, you are not using the image itself, you are using its alpha channel as a mask that separates a yellow color and (?) nothing (which will look black). Plus you have a first Mix Shader that is useless. And you should precise what kind of shader you want for your Image Texture, either Emission or Diffuse.

A more correct node setup would be this one: Plug your Image Texture into Color > MixRGB node, plug the Alpha output into the MixRGB factor input, choose the color you want in the other MixRGB color field, plug the MixRGB into a Diffuse or an Emission (here the Principled BSDF is used as a Diffuse)

enter image description here

$\endgroup$
2
  • $\begingroup$ Mr/Ms Moonboots thank you very much for the answer😊. Now my Lego facial color is correct. I'm still new for the nodes, so i still need learning much about the node. Thank you for the help. $\endgroup$ Jun 21 '21 at 10:05
  • $\begingroup$ @HandyHintha You might consider accepting this answer, please read here: What should I do when someone answers my question? $\endgroup$ Jun 21 '21 at 10:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.